Bug 1220890 - --acls option sets default ACLs irregardless of ACLs set within the tarball
Summary: --acls option sets default ACLs irregardless of ACLs set within the tarball
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tar
Version: 7.1
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.2
Assignee: Pavel Raiskup
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1203710 1289025 1295829 1313485
TreeView+ depends on / blocked
 
Reported: 2015-05-12 18:36 UTC by Kyle Squizzato
Modified: 2019-11-14 06:43 UTC (History)
9 users (show)

Fixed In Version: tar-1.26-31.el7
Doc Type: Bug Fix
Doc Text:
Cause: Automatic default ACLs (Access Control Lists) inheritance from parent directory during file creation. Consequence: Tar incorrectly let the file inherit default ACLs during extraction with --acls option. Fix: Now, after a file is extracted under any directory (directory with or without default ACLs set), the automatically inherited default ACLs are cleared and only correct ACLs are set afterwards to mirror the real archive contents. Result: With --acls option on, tar extracts all files and directories with the same ACLs as are set in archive.
Clone Of:
: 1220891 (view as bug list)
Environment:
Last Closed: 2016-11-04 00:21:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2199 0 normal SHIPPED_LIVE tar bug fix update 2016-11-03 13:22:03 UTC

Description Kyle Squizzato 2015-05-12 18:36:42 UTC
Description of problem:
When a tarball is extracted using --acls option the default ACLs for directories are set despite the tarball doesn't have default ACLS set in them. 

Version-Release number of selected component (if applicable):
tar-1.26-29.el7.x86_64

How reproducible:
Always 

Steps to Reproduce:
1. Apply some acls to a set of files/directories 
2. Tar them up 
3. Extract them 
4. View the acls set on the files/directories, they will be default acls

Actual results:
Using the --acls flag causes default ACLs to be applied on extraction. 

Expected results:
Use the --acls flag to preserve ACLs when extracting files and directories

Additional info: 
This has been resolved upstream: http://pkgs.fedoraproject.org/cgit/tar.git/commit/tar-1.27.1-default-acls.patch?h=f21&id=486bd7adf8f8ba625d937b1016bc2fe366569089

and is discussed here: https://www.mail-archive.com/bug-tar@gnu.org/msg04355.html

Comment 14 errata-xmlrpc 2016-11-04 00:21:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2199.html


Note You need to log in before you can comment on or make changes to this bug.