Bug 1220891 - --acls option sets default ACLs irregardless of ACLs set within the tarball
Summary: --acls option sets default ACLs irregardless of ACLs set within the tarball
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar
Version: 6.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 6.8
Assignee: Pavel Raiskup
QA Contact: qe-baseos-daemons
Lenka Špačková
URL:
Whiteboard:
Depends On:
Blocks: 1172231 1269927
TreeView+ depends on / blocked
 
Reported: 2015-05-12 18:39 UTC by Kyle Squizzato
Modified: 2019-11-14 06:43 UTC (History)
6 users (show)

Fixed In Version: tar-1.23-14.el6
Doc Type: Bug Fix
Doc Text:
*tar* now correctly sets ACL when `--acls` is used Previously, when a tar file was extracted using the `--acls` option, the extracted files inherited the default Access Control Lists (ACL) from the parent directory. With this update, when `--acls` is used, *tar* extracts all files and directories with the same ACLs that are set in the archive.
Clone Of: 1220890
Environment:
Last Closed: 2016-05-10 19:40:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0750 0 normal SHIPPED_LIVE tar bug fix update 2016-05-10 22:31:49 UTC

Description Kyle Squizzato 2015-05-12 18:39:35 UTC
+++ This bug was initially created as a clone of Bug #1220890 +++

Description of problem:
When a tarball is extracted using --acls option the default ACLs for directories are set despite the tarball doesn't have default ACLS set in them. 

Version-Release number of selected component (if applicable):
tar-1.26-29.el7.x86_64

How reproducible:
Always 

Steps to Reproduce:
1. Apply some acls to a set of files/directories 
2. Tar them up 
3. Extract them 
4. View the acls set on the files/directories, they will be default acls

Actual results:
Using the --acls flag causes default ACLs to be applied on extraction. 

Expected results:
Use the --acls flag to preserve ACLs when extracting files and directories

Additional info: 
This has been resolved upstream: http://pkgs.fedoraproject.org/cgit/tar.git/commit/tar-1.27.1-default-acls.patch?h=f21&id=486bd7adf8f8ba625d937b1016bc2fe366569089

and is discussed here: https://www.mail-archive.com/bug-tar@gnu.org/msg04355.html

Comment 1 Kyle Squizzato 2015-05-12 18:41:32 UTC
For RHEL6 the Version-Release number of selected component (if applicable) is: 
tar-1.23-11.el6.x86_64

Comment 8 errata-xmlrpc 2016-05-10 19:40:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0750.html


Note You need to log in before you can comment on or make changes to this bug.