This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 122159 - Easy config for ssh-add passphrase during login
Easy config for ssh-add passphrase during login
Status: CLOSED DUPLICATE of bug 67823
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 23:27 EDT by Larry Underhill
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 11:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Larry Underhill 2004-04-30 23:27:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
A user should be able to specify that ssh-add run when their X session
is initiated. When the X session comes up, ssh-add is running, but the
user can not see the dialog box to enter password because it is still
obscured by gdm splash screen.

Version-Release number of selected component (if applicable):
gnome-session-2.2.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. Configure ssh-add in gnome-session so that ssh passphrase is
prompted for when X starts: Preferences -> More Preferences ->
Sessions. In 'Startup Programs' tab click 'Add'. Startup Command =
'ssh-add' and Order = 55. Click Close.

2. Log out of X session

3. Log back into X session. You will see the Fedora gdm splash screen
with logos for the services starting up. 

4. After a few seconds you will see ssh-add listed in splash screen,
but no dialog box to enter password. Dialog box is actually behind gdm
splash screen. If you type your passphrase it will load the key into
your agent.
    

Actual Results:  No passphrase dialog box

Expected Results:  user should be able to see passphrase dialog box

Additional info:

After I finished typing this, I checked out my rpms and I see:

[larry@lupin larry]$ rpm -qa | grep session
gnome-session-2.2.0.2-4
gnome-session-2.4.0-1

This workstation was upgraded from RH 8.0 -> Fedora Core 1 via yum, so
I don't know why I have two gnome-session rpms installed. Will check
this out to see if it is source of problem...
Comment 1 Warren Togami 2004-11-29 17:06:49 EST
[warren@ibmlaptop ~]$ cat .Xclients-default
ssh-add < /dev/null
exec gnome-session

I personally use this for ssh-add during login, which doesn't have a
problem.  I agree that we should make this easier to configure,
perhaps with a GUI checkbox.

FC4Target
Comment 2 Ray Strode [halfline] 2005-04-07 15:21:37 EDT
This is a problem that has been discussed before.  Unfortunately I don't think
it's going to get looked at in time for FC4.
Comment 3 Ray Strode [halfline] 2005-04-08 11:12:43 EDT

*** This bug has been marked as a duplicate of 67823 ***

Note You need to log in before you can comment on or make changes to this bug.