Bug 67823 - Put ssh-add in default session
Put ssh-add in default session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 122159 (view as bug list)
Depends On:
Blocks: 130104
  Show dependency treegraph
 
Reported: 2002-07-02 11:12 EDT by Jonathan Blandford
Modified: 2013-04-02 00:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 00:37:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-07-02 11:12:44 EDT
Xsession now runs ssh-agent by default. Put ssh-add in the default session.

(Implementation issue, I don't think ssh-add is session aware.)
Comment 1 Havoc Pennington 2002-07-15 00:09:49 EDT
Rather than putting it in the session we may just need to hack the gnome-session
source, or the scripts in xinitrc. Of course then people can't get rid of it.
Comment 2 Preston Brown 2002-07-15 14:43:48 EDT
 I managed to get it into my default session by running the utility for managing startup 
programs, so it shouldn't need to be hardcoded.
Comment 3 Havoc Pennington 2002-07-29 12:24:22 EDT
Marking the head of the priority queue with priority high
Comment 4 Kjartan Maraas 2004-03-29 16:52:29 EST
Is this still relevant?
Comment 5 Ray Strode [halfline] 2005-04-08 11:02:06 EDT
Yes.  Ideally we'd forward credentials from pam or something so the user doesn't
have to enter a password twice.  That gets complicated when you factor in
ssh-agent and that the password associated with a ssh key doesn't have to match
the login password.

Before adding to the default session we need to investigate what happens if the
user doesn't have ssh-gnome-askpass installed or if SSH_ASKPASS is configured to
use the terminal ask pask program.  Does it detect that we aren't attached to a
tty and exit quietly or does it hang around waiting for forever?

Comment 6 Ray Strode [halfline] 2005-04-08 11:12:50 EDT
*** Bug 122159 has been marked as a duplicate of this bug. ***
Comment 7 Gregory Leblanc 2005-04-08 18:26:37 EDT
Ray asked me to test behaviour with some variations of ssh-askpass and
ssh-askpass-gnome installed.  Tested out what happens with no askpass program
installed (prints an error to stdout, returns), what happens with only the
openssh-askpass program installed (displays the slightly uglier X-only askpass),
and with both installed, and my environment's SSH_ASKPASS set to null, the
openssh-askpass program, and the openssh-askpass-gnome program.  Behavior seems
to be much as expected, the X only program runs unless SSH_ASKPASS is set
explicitly to the GNOME version.  
Comment 9 Matthias Clasen 2008-04-17 00:37:17 EDT
This bug has been obsoleted by gnome-keyrings growing of ssh-agent support, I
beleive.

Note You need to log in before you can comment on or make changes to this bug.