Bug 1221635 - add dnf config option to (not)obey weak deps
add dnf config option to (not)obey weak deps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
: 1229701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-14 09:14 EDT by Jan Kratochvil
Modified: 2016-11-27 16:30 EST (History)
12 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:14:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2015-05-14 09:14:30 EDT
Description of problem:
mock chroots have now needless dependencies.

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.8-1.fc22.noarch

How reproducible:
Always.

Steps to Reproduce:
https://lists.fedoraproject.org/pipermail/devel/2015-May/210603.html

Actual results:
22 more packages get installed than with older 'gdb' which did not 'Recommends: dnf-plugins-core'

Expected results:
No or minimal additional packages installed.

Additional info:
Newest GDB build
  http://pkgs.fedoraproject.org/cgit/gdb.git/commit/?id=d03633a0c051f7f636d7bdca66d397705d7e12bc
already uses:
  Recommends: dnf-command(debuginfo-install)
so that it would work with the split.

I have no idea if Requires of 'debuginfo-install' would be smaller than the current Requires of whole 'dnf-plugins-core'.

If Requires of split-out 'debuginfo-install' would be the same then I think this Bug can be CLOSED as INVALID/WONTFIX and I will have to split GDB instead - by moving /usr/bin/gdb to /usr/libexec/gdb to be used by /usr/bin/gdb-add-index and to have additional stub gdb.rpm with symlink /usr/libexec/gdb->/usr/bin/gdb will all the additional Requires+Recommends for practical use of GDB.
Comment 1 Radek Holy 2015-05-14 09:40:40 EDT
Is 'debuginfo-install' needed in all mock chroots? Otherwise it should be enough to install 'gdb' without the 'recommended' packages.
Comment 2 Jan Kratochvil 2015-05-14 09:45:07 EDT
mock chroots need only /usr/bin/gdb-add-index.
/usr/bin/gdb-add-index is a shell script using /usr/bin/gdb.
/usr/bin/gdb for its full use by users needs 'debuginfo-install'.

Another topic is whether mock should be installing Recommended packages or not, feel free to reassign or file a new Bug to mock if you think so.
Comment 3 Honza Silhan 2015-05-15 08:00:45 EDT
(In reply to Jan Kratochvil from comment #0)
> http://pkgs.fedoraproject.org/cgit/gdb.git/commit/
> ?id=d03633a0c051f7f636d7bdca66d397705d7e12bc
> already uses:
>   Recommends: dnf-command(debuginfo-install)

From gdb POV you're doing it right. In same cases whole dnf-plugins-core are unnecessary. The question is whether to separate just this plugin or all of them and make dnf-plugins a group with mandatory packages from core and optional from extras. We will figure out.

> I have no idea if Requires of 'debuginfo-install' would be smaller than the
> current Requires of whole 'dnf-plugins-core'.

It will be.

(In reply to Jan Kratochvil from comment #2)
> Another topic is whether mock should be installing Recommended packages or
> not, feel free to reassign or file a new Bug to mock if you think so.

Then we would need to file the bug for DNF first to allow/disallow pulling in weak dep packages.
Comment 4 Honza Silhan 2015-07-22 08:45:22 EDT
I am changing it to bug report for dnf config option to forbit installation of weak deps.
Comment 5 Honza Silhan 2015-07-24 08:10:56 EDT
*** Bug 1229701 has been marked as a duplicate of this bug. ***
Comment 6 Honza Silhan 2015-07-31 12:50:02 EDT
PR: https://github.com/rpm-software-management/dnf/pull/325
Comment 7 Fedora Update System 2015-08-10 06:05:43 EDT
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23
Comment 8 Fedora Update System 2015-08-10 06:49:49 EDT
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
Comment 9 Fedora Update System 2015-08-10 22:11:01 EDT
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2015-08-14 22:14:23 EDT
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-08-19 03:51:31 EDT
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Viliam Križan 2016-11-27 16:30:25 EST
I would expect a `builddep` command to skip downloading weak dependencies by default. Then the mock (bug 1254634) did not need to change... and probably other tools that download a build dependencies (e.g. scripts to build RPM outside of mock). Or, will it break something?

Skipping weak dependencies may have an CLI option, e.g. --skip-weak, for users' to find out that this feature exist and for ease of use when doing a minimal install.

Thank you for any info.

Note You need to log in before you can comment on or make changes to this bug.