Bug 1254634 - Buldroot prepared by DNF is significantly larger
Summary: Buldroot prepared by DNF is significantly larger
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-18 14:21 UTC by Vít Ondruch
Modified: 2015-10-07 04:06 UTC (History)
15 users (show)

Fixed In Version: 1.2.13-2.fc22 mock-1.2.13-2.fc21 mock-1.2.13-2.el7 mock-1.2.13-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 04:10:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock output using YUM (94.67 KB, text/plain)
2015-08-18 14:21 UTC, Vít Ondruch
no flags Details
mock output using DNF (94.67 KB, text/plain)
2015-08-18 14:22 UTC, Vít Ondruch
no flags Details
mock output using YUM (111.54 KB, text/plain)
2015-08-18 14:31 UTC, Vít Ondruch
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1221635 None CLOSED add dnf config option to (not)obey weak deps 2019-03-03 17:13 UTC

Internal Trackers: 1221635

Description Vít Ondruch 2015-08-18 14:21:19 UTC
Description of problem:
Mock Rawhide build root prepared by DNF is way larger then build root prepared by Yum (210 vs 171) packages. This speaks against DNF, so I guess you'd like probably to investigate and suggest some fixes to some packages.


Version-Release number of selected component (if applicable):
$ rpm -q mock
mock-1.2.12-1.fc22.noarch

$ rpm -q dnf
dnf-1.0.2-3.fc22.noarch

$ rpm -q yum
yum-3.4.3-505.fc22.noarch


How reproducible:
Always

Steps to Reproduce:
1. $ mock -r fedora-rawhide-x86_64 --init
2. # sed -i '/package_manager/ s/^/#/' /etc/mock/fedora-rawhide-x86_64.cfg 
3. $ mock -r fedora-rawhide-x86_64 --init

Actual results:
YUM: 171 packages
DNF: 210 packages

Expected results:
YUM: 171 packages
DNF: similar or smaller number of packages


Additional info:

Comment 1 Vít Ondruch 2015-08-18 14:21:51 UTC
Created attachment 1064332 [details]
mock output using YUM

Comment 2 Vít Ondruch 2015-08-18 14:22:24 UTC
Created attachment 1064333 [details]
mock output using DNF

Comment 3 Vít Ondruch 2015-08-18 14:31:38 UTC
Created attachment 1064336 [details]
mock output using YUM

Comment 4 Radek Holy 2015-08-18 14:54:41 UTC
Or maybe the Mock maintainers "'d like probably to investigate"... :-D

OK, I can give them a hint: "install_weak_deps=".

Comment 5 Miroslav Suchý 2015-08-18 14:56:19 UTC
I wonder why DNF output have there python3-dnf (and basically all those DNF packages)? Mock does not install it. Whose deps take the DNF in?

Comment 6 Radek Holy 2015-08-18 15:03:56 UTC
That's a good question. I guess something requires DNF's repoquery since dnf-plugins-core are installed as well?

Comment 7 Radek Holy 2015-08-18 15:05:37 UTC
Anyway, it's pulled in only if the weak dependencies are enabled. I guess it's pulled in by gdb. See the bug I referenced above.

Comment 8 Miroslav Suchý 2015-08-18 15:08:01 UTC
With install_weak_deps=0 in config it is only 185 packages. This is still more then 171 with yum. But still lower then 210 without this option.

Comment 9 Radek Holy 2015-08-18 15:09:35 UTC
Interesting... It's 171 on my system...

Comment 10 Miroslav Suchý 2015-08-18 15:16:45 UTC
install_weak_deps=0 added to all config where DNF is used by default

Commit:
* 7601fe2 (origin/devel) do not install weak deps in chroot [RHBZ#1254634]

Comment 11 Miroslav Suchý 2015-08-18 15:22:47 UTC
It is 185 even with yum on my system (for fedora-23-x86_64 target). We are probably using different targets.
Anyway - we are on par with yum now. I rest my case.

Comment 12 Miroslav Suchý 2015-08-24 09:58:41 UTC
*** Bug 1256011 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2015-09-16 20:01:58 UTC
mock-1.2.13-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16053

Comment 14 Fedora Update System 2015-09-16 20:04:56 UTC
mock-1.2.13-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16054

Comment 15 Fedora Update System 2015-09-16 20:06:55 UTC
mock-1.2.13-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16056

Comment 16 Fedora Update System 2015-09-16 20:08:39 UTC
mock-1.2.13-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8114

Comment 17 Fedora Update System 2015-09-16 20:09:45 UTC
mock-1.2.13-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8115

Comment 18 Fedora Update System 2015-09-17 21:30:07 UTC
mock-1.2.13-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16054

Comment 19 Fedora Update System 2015-09-18 05:21:02 UTC
mock-1.2.13-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16056

Comment 20 Fedora Update System 2015-09-18 16:24:25 UTC
mock-1.2.13-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16053

Comment 21 Fedora Update System 2015-09-19 03:19:56 UTC
mock-1.2.13-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8115

Comment 22 Fedora Update System 2015-09-19 03:21:46 UTC
mock-1.2.13-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8114

Comment 23 Fedora Update System 2015-09-23 04:09:42 UTC
mock-1.2.13-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2015-09-24 08:22:41 UTC
mock-1.2.13-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2015-10-05 22:50:37 UTC
mock-1.2.13-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2015-10-07 03:05:06 UTC
mock-1.2.13-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2015-10-07 04:05:03 UTC
mock-1.2.13-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.