Bug 12217 - Xconfigurator still gives wrong values for Cyrix
Xconfigurator still gives wrong values for Cyrix
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 15:01 EDT by Telsa Gwynne
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 18:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bad XF86Config generated by Xconfigurator for Cyrix MediaGX (6.19 KB, text/plain)
2000-07-17 04:02 EDT, Telsa Gwynne
no flags Details

  None (edit)
Description Telsa Gwynne 2000-06-13 15:01:23 EDT
See bug #7551. I have not added a comment to that because I can't change
the version to Winston beta, and if I set it to beta-team only, anyone
hunting correct Cyrix values won't be able to see them any more.

Xconfigurator still attempts to persuade me that my Cyrix MediaGX attached
to a Sony CPD-110EST can perform the miracle of 1280x1024x8bit. It can't. 
The best it can achieve is 1024x768.

Now, however, when I tell it to use up to 1024x768 for eight-bit and
16-bit and nothing for 24-bit, in the Winston beta, it tells me, 
"There is a problem with your X configuration. You may go back and
modify values or quit now."
Comment 1 Trond Eivind Glomsrxd 2000-07-12 13:11:02 EDT
Please test this with beta3?
Comment 2 Telsa Gwynne 2000-07-16 12:19:23 EDT
Still breaks, but differently.

(a) Selecting MediaGX in XConfigurator blows XConfigurator up. It's looking for 
../../usr/X11R6/bin/SVGA. It should look for ../../usr/X11R6/bin/XF86_SVGA. A
temporary fix is to symlink them.

(b) Still suggests values of 1280x1024x8bit. Cyrix MediaGX can't do that.

(c) Allows you to tell it values up to and including 1024x768 for 8 and 16-bit
and accepts them: runs the test, the test works, and then it writes values to
the
XF86Config which are all wrong. Running startx after it worked once (by lucky
chance a modeline for 640x480 worked). I tried tinkering with the file, got lots
of
funky errors, then put the original file back and X still wouldn't work. 

So I don't get the "There is a problem with your X configuration" message, but
the results are still pretty bad.  Sorry.
Comment 3 Telsa Gwynne 2000-07-17 04:02:28 EDT
Created attachment 1207 [details]
Bad XF86Config generated by Xconfigurator for Cyrix MediaGX
Comment 4 Telsa Gwynne 2000-07-17 04:04:35 EDT
Further investigation: 'startx' and 'startx -- -bpp 8' work: I get a 
640x480 display, but it works. 'startx -- -bpp 16' produces the
machine hang. Offending XF86Config attached.
Comment 5 Trond Eivind Glomsrxd 2000-07-18 18:06:09 EDT
Weird. Please test the Xconfigurator shipped with beta4 and update the info.
Comment 6 Trond Eivind Glomsrxd 2000-07-27 14:25:48 EDT
Please test beta 5 and update info.
Comment 7 Alan Cox 2000-08-01 18:31:23 EDT
Still broken. In fact quite obviously nobody has made any attempt to fix this.

Its not hard

If they select MediaGX (which btw should be listed as Cyrix MediaGX for
consistency)

Do not offer 1280x1024
Generate the mode lines differently. The 2nd value of the X is always 16+ the
first, the rest are
unchanged. Its only been broken since about 5.0 and it isnt hard to fix
The machine hang is fixed in pinstripe, and replaced by an X rendering bug
instead. That will get
filed seperately as an X11 bug.

Comment 8 Telsa Gwynne 2000-08-02 08:27:09 EDT
Okay, now I start it, it still says, "Ooh, a Cyrix" and suggests the wrong
values.
When I refuse to accept them and tell it all resolutions up to 1024x768 for both
8 and 16 bpp, it says 'okay', survives the test, tells me it worked and then
I startx and get 640x480 again. 

It doesn't seem to be crashing yet, though.
Comment 9 Trond Eivind Glomsrxd 2000-08-02 10:16:15 EDT
I haven't tried any specific fixes due to lack of hardware (we only have a
non-working one). When it comes to offering 1280x1024, that's not going to be
solved - the current Xconfigurator does not have an infrastructure to add this
(which is also a problem with laptops with LCD displays). It will be fixed in
the upcoming from-scratch rewrite (at least, it is on my list of things I want
in there - I want to have an intersection of possible values for card and
monitor).

The modeline problem:

Take e.g.

Modeline "1024x768"    85    1024 1032 1152 1360   768  784  787  823

Are you saying that what you want is:

Modeline "1024x768"    85    1024 1040 1152 1360   768  784  787  823

Will that affect others in a bad way? (iow: time to add yet another "if" case
for Xconfigurator?)

BTW: Does it work with any XFree 4 driver?





Comment 10 Alan Cox 2000-08-02 11:45:25 EDT
Modeline problem:

You have this right yes, and its MediaGX specific. Basically you read A B C D
from the reference
mode dbase and output A A+16 C D for a Cyrix MediaGX based chip. Probably you
need another
skeleton modedb file solely for this annoying chip.

Comment 11 Trond Eivind Glomsrxd 2000-08-02 16:53:07 EDT
These lines are hardcoded in Xconfigurator - will fixing this modeline only fix
it, or do all modelines have to be exactly this way for MediaGX?
Comment 12 Alan Cox 2000-08-02 18:24:06 EDT
The MediaGX needs all its usable modelines this way. (640->1024 only need
doing). The MediaGX  fixed lines naturally dont work on non MediaGX 8)

If time is short then just fixing a few 800x600 and 1024x768 entries should at
least get people up and running
Comment 13 Trond Eivind Glomsrxd 2000-08-02 21:09:10 EDT
Try Xconfigurator 4.3.38 from  http://people.redhat.com/teg/xc/ - the modelines
should say they are specific to MediaGX. If that doesn't happen or the modelines
are wrong, reopen - the latter with proper modelines.

Note You need to log in before you can comment on or make changes to this bug.