Bug 122181 - Menus in both Gnome and KDE missing Kate, Kwrite entries
Summary: Menus in both Gnome and KDE missing Kate, Kwrite entries
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Seth Nickell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-01 16:19 UTC by Gerry Tool
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 15:43:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerry Tool 2004-05-01 16:19:58 UTC
Description of problem:Even though Kate and Kwrite are installed and
executable from the cli, the menus do not include entries for them.


Version-Release number of selected component (if applicable):
redhat-menus-1.4-1

How reproducible: Always


Steps to Reproduce:
1.Select menu in either Gnome or KDE and look for Kate and Kwrite
2.
3.
  
Actual results: No entry found


Expected results: Should find an entry to execute app


Additional info: There may be others; I have not made an exhaustive
search.

Comment 1 Bryan W Clark 2004-11-02 21:18:02 UTC
redhat-menus -> koffice

Comment 2 Rex Dieter 2004-11-02 22:12:51 UTC
Why (re)assign to koffice?  It's clearly a redhat-menus misgiving.

Comment 3 Rex Dieter 2004-11-02 22:14:39 UTC
See proposed patch in bug #137796 to create an "Editors" menu to 
contain this currently missing items.

Comment 4 Rex Dieter 2004-11-02 22:15:21 UTC
*** Bug 137796 has been marked as a duplicate of this bug. ***

Comment 5 Ngo Than 2004-11-03 10:37:56 UTC
it's a bug in redhat-menus, reassign to correct component

Comment 6 Seth Nickell 2004-11-03 21:43:10 UTC
On a technical level, what is the bug? Is Kate/Kwrite not including
category keywords that we know about?

Comment 7 Rex Dieter 2004-11-03 21:53:42 UTC
The bug being that Kate/Kwrite (or any app that includes 
Categories=TextEditor)
doesn't appear anywhere in the menus.  Once consequence of that (in 
KDE at least), is that they cannot be chosen to as the default app to 
handle their supported MimeTypes, like text/plain.

Comment 8 Rex Dieter 2004-11-24 16:52:12 UTC
An errata was released (redhat-menus-3.7.1-1.fc3), why wasn't this fix
included? 

Comment 9 Ngo Than 2005-03-21 15:43:05 UTC
it's fixed in redhat-menus-3.7.1-7. it will showup in rawhide soon.

Comment 10 Rex Dieter 2005-03-21 16:48:47 UTC
Did you use the patch for an added "Editors" menu, or did you put these items
elsewhere in the menus?

Comment 11 Ngo Than 2005-03-21 17:14:53 UTC
Kate will show up in Development and kedit/kwrite in Accessories

Comment 12 Rex Dieter 2005-03-22 15:28:38 UTC
The real problem is that items with 
Category=TextEditor
are not handled with the current redhat menus(-3.7.1)

IMO, the "fix" as implemented is a hack, hard-coding menu locations for known
unhandled (ie TextEditor) applications (eg, kedit, kwrite, kate).  This problem
will raise itself again, as soon as any other 
Category=TextEditor
application is ever installed.

I'll reopen bug #137796 to address this larger issue.

p.s. AFAIK, kedit is no longer present in kde-3.4.0


Note You need to log in before you can comment on or make changes to this bug.