Bug 122187 - Installation software does not create a bootable floppy
Installation software does not create a bootable floppy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 122185 122186 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 13:45 EDT by Chris Meyer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 13:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Meyer 2004-05-01 13:45:49 EDT
Description of problem:
The new installation software does not make a bootable floppy disk.  
Therefore, it is impossible to boot into linux.  A message appears on 
the screen that I cannot use the boot loader, and to boot from floppy.

The rescue software also did not allow a bootable floppy to be 
created using mkbootfloppy.  Possible there is another way to make a 
bootable floppy.

Also, it is impossible to change the configuration for the boot 
loader if no packages have been updated.

Version-Release number of selected component (if applicable):


How reproducible:
Install Red Hat Linux version 1.92 and do not install the boot loader.

Steps to Reproduce:
1.  Put Red Hat installation disk in drive and reboot.
2.  Follow menu for installation and do not install boot loader.
3.
  
Actual results:
Cannot boot into linux.

Expected results:
In the installation, an option should be provided to make a boot 
floppy.

Additional info:
Comment 1 Alan Cox 2004-05-02 17:48:48 EDT
The 2.6 kernel no longer fits on a floppy disk. The installer does not
allow creation of such floppies therefore. There is a bug where it
spits out a warning about needing floppies, but the warning and
partition stuff appears to be the real problem.
Comment 2 Alan Cox 2004-05-02 17:49:31 EDT
*** Bug 122186 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2004-05-02 17:50:06 EDT
*** Bug 122185 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2004-05-03 13:53:41 EDT
The warning is covered by another bug.  The 2.6 kernel won't fit on a
floppy, so I can't really do anything to create one.
Comment 5 Chris Meyer 2004-05-03 14:31:07 EDT
It would be nice to have the feature to boot from a CD or DVD.  Most 
computers can boot from CD now.
Comment 6 LarryT 2004-07-21 10:10:24 EDT
Hi !
There is something i don't understand : i did do a floppy bootdisk of
the fedora core 2 (kernel 2.6.5-1.358) without any problem !
The command i used for is : mkbootdisk, and the global syntaxe was :
mkbootdisk --device /dev/fd0 numberofthekernel.

So i don't understand where the problem lies.
Have a nice day, bye :)

Note You need to log in before you can comment on or make changes to this bug.