Bug 1221903 - Logwatch cron files not marked correctly as %config(noreplace) - Fixed in Fedora
Summary: Logwatch cron files not marked correctly as %config(noreplace) - Fixed in Fedora
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: logwatch   
(Show other bugs)
Version: 7.1
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: Martin Frodl
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks: 1289485 1313485 1221963
TreeView+ depends on / blocked
 
Reported: 2015-05-15 08:15 UTC by Simone Caronni
Modified: 2016-11-04 03:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1221963 (view as bug list)
Environment:
Last Closed: 2016-11-04 03:30:24 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2312 normal SHIPPED_LIVE logwatch bug fix update 2016-11-03 13:41:34 UTC

Description Simone Caronni 2015-05-15 08:15:18 UTC
Description of problem:

/etc/cron.daily/0logwatch is not marked as a configuration file, so any change to it is not preserved. This makes impossible to customize logwatch behaviour, as with any update the cron script is replaced; making logwatch pretty useless.

Version-Release number of selected component (if applicable):

7.4.0-28.20130522svn140.el7

How reproducible:

Always

Steps to Reproduce:
1. Install logwatch
2. Edit /etc/cron.daily/0logwatch
3. Reinstall or update logwatch

Actual results:

The file is overwritten, it should not be.

Expected results:

The file should not be overwritten and should be preserved.

Additional info:

Fedora logwatch package has the proper fix in place since August 2013 (!):

http://pkgs.fedoraproject.org/cgit/logwatch.git/tree/logwatch.spec#n166

While RHEL 7, being branched before, does not have it. Please backport the fix, it is simply as marking the logwatch file %config(noreplace).

Comment 2 Simone Caronni 2015-05-15 08:18:40 UTC
Original thread:

http://sourceforge.net/p/bacula/mailman/message/34113406/

Comment 3 Dimitri Maziuk 2015-05-15 14:47:51 UTC
*Note* that in RHEL (centos) 6 adding "save = /some/file" to logwatch.conf worked and this was "notabug" at least as far as changing the output destination goes.

In centos 7 cron.daily/0logwatch runs it with "--output=mail" overriding logwatch.conf -- that is the problem as far as I'm concerned.

Comment 9 errata-xmlrpc 2016-11-04 03:30:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2312.html


Note You need to log in before you can comment on or make changes to this bug.