Bug 1221963 - Logwatch cron files not marked correctly as %config(noreplace) - Fixed in Fedora
Summary: Logwatch cron files not marked correctly as %config(noreplace) - Fixed in Fedora
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch
Version: 6.8
Hardware: All
OS: All
high
high
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: Martin Frodl
URL:
Whiteboard:
Depends On: 1221903
Blocks: 1172231 1270825
TreeView+ depends on / blocked
 
Reported: 2015-05-15 10:49 UTC by Jan Synacek
Modified: 2016-01-11 13:23 UTC (History)
6 users (show)

Fixed In Version: logwatch-7.3.6-53.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1221903
Environment:
Last Closed: 2016-01-11 13:23:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0020 normal SHIPPED_LIVE logwatch bug fix update 2016-01-11 18:23:07 UTC

Description Jan Synacek 2015-05-15 10:49:32 UTC
+++ This bug was initially created as a clone of Bug #1221903 +++

Description of problem:

/etc/cron.daily/0logwatch is not marked as a configuration file, so any change to it is not preserved. This makes impossible to customize logwatch behaviour, as with any update the cron script is replaced; making logwatch pretty useless.

Version-Release number of selected component (if applicable):

7.4.0-28.20130522svn140.el7

How reproducible:

Always

Steps to Reproduce:
1. Install logwatch
2. Edit /etc/cron.daily/0logwatch
3. Reinstall or update logwatch

Actual results:

The file is overwritten, it should not be.

Expected results:

The file should not be overwritten and should be preserved.

Additional info:

Fedora logwatch package has the proper fix in place since August 2013 (!):

http://pkgs.fedoraproject.org/cgit/logwatch.git/tree/logwatch.spec#n166

While RHEL 7, being branched before, does not have it. Please backport the fix, it is simply as marking the logwatch file %config(noreplace).

--- Additional comment from Simone Caronni on 2015-05-15 10:18:40 CEST ---

Original thread:

http://sourceforge.net/p/bacula/mailman/message/34113406/

Comment 1 Dimitri Maziuk 2015-05-15 14:49:34 UTC
*Note* that in RHEL (centos) 6 adding "save = /some/file" to logwatch.conf worked last I tried so this was "notabug" at least as far as changing the output destination goes.

In centos 7 cron.daily/0logwatch runs it with "--output=mail" overriding logwatch.conf -- that is the problem as far as I'm concerned.

Comment 8 errata-xmlrpc 2016-01-11 13:23:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0020.html


Note You need to log in before you can comment on or make changes to this bug.