Bug 1222097 - plasma-workspace depends on NetworkManager (RFE)
Summary: plasma-workspace depends on NetworkManager (RFE)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1261034
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2015-05-15 18:29 UTC by Ivan Viktorov
Modified: 2016-06-28 21:55 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-21 23:27:03 UTC


Attachments (Terms of Use)
SPEC file patch (4.86 KB, patch)
2015-09-22 20:02 UTC, Ian Pilcher
no flags Details | Diff

Description Ivan Viktorov 2015-05-15 18:29:45 UTC
Description of problem:

I want to remove NetworkManager from my system, but plasma-workspace depends on it. In kde4 and plasma-workspace-5.2.2.fc22 only plasma-nm applet depends on NetworkManager. But plasma-workspace-5.3.0-3.fc22 and later depends on kf5-networkmanager-qt which depends on NM. So I can't remove it. Maybe there is a way to split it, or move to plasma-nm.

Version-Release number of selected component (if applicable):

plasma-workspace >= 5.3.0

How reproducible:

dnf install plasma-workspace.x86_64 and try dnf remove NetworkManager.x86_64

Steps to Reproduce:
1.dnf install plasma-workspace.x86_64
2.dnf remove NetworkManager.x86_64
3.

Actual results:

Can't remove NetworkManager without removing plasma-workspace

Expected results:


Additional info:

Comment 1 Rex Dieter 2015-05-15 18:35:41 UTC
*If* we were to fix this, it would have to be in kf5-networkmanager-qt5

The current dependency chain is:

plasma-workspace -> kf5-networkmanager-qt5 -> NetworkManager

Comment 2 Ivan Viktorov 2015-05-15 18:57:17 UTC
(In reply to Rex Dieter from comment #1)
> *If* we were to fix this, it would have to be in kf5-networkmanager-qt5
> 
> The current dependency chain is:
> 
> plasma-workspace -> kf5-networkmanager-qt5 -> NetworkManager

Maybe I'm wrong, but it would be strange if kf5-networkmanager-qt5 won't require NetworkManager. I hope it's possible for plasma-workspace to not require kf5-networkmanager-qt5.

Comment 3 Rex Dieter 2015-05-15 19:04:37 UTC
Fwiw, plasma-workspace bits that link libKF5NetworkManagerQt:

qt5_plugindir/plasma-geolocation-ip.so
qt5_plugindir/plasma/dataengine/plasma_engine_geolocation.so

OK, so splitting these out may be an option too.

Comment 4 Jan Grulich 2015-05-16 05:23:31 UTC
I think that kf5-networkmanager-qt5 should require Networkmanager, which makes sense, because it doesn't work without it. I would vote for splitting plasma-geolocation from plasma-workspace for those who want to remove NetworkManager.

Comment 5 Ian Pilcher 2015-09-11 14:54:46 UTC
(In reply to Rex Dieter from comment #3)
> OK, so splitting these out may be an option too.

I propose that the following files be moved into a plasma-workspace-geolocation sub-package:

/usr/lib64/libplasma-geolocation-interface.so.5
/usr/lib64/libplasma-geolocation-interface.so.5.4.0
/usr/lib64/qt5/plugins/plasma-geolocation-gps.so
/usr/lib64/qt5/plugins/plasma-geolocation-ip.so
/usr/lib64/qt5/plugins/plasma/dataengine/plasma_engine_geolocation.so
/usr/share/kservices5/plasma-dataengine-geolocation.desktop
/usr/share/kservices5/plasma-geolocation-gps.desktop
/usr/share/kservices5/plasma-geolocation-ip.desktop
/usr/share/kservicetypes5/plasma-geolocationprovider.desktop

(I've removed these files from my test system, and things seem to be working just fine.)

These files would go into plasma-workspace-geolocation-devel:

/usr/include/plasma/geolocation
/usr/include/plasma/geolocation/geolocation_export.h
/usr/include/plasma/geolocation/geolocationprovider.h
/usr/lib64/libplasma-geolocation-interface.so

I can come up with a patch to the SPEC file, if this is deemed an acceptable solution.

Comment 6 Rex Dieter 2015-09-11 15:00:31 UTC
Imo, there's much less need for a -devel split, we're mostly concerned about runtime deps here.

Comment 7 Rex Dieter 2015-09-11 15:01:49 UTC
I guess one concern I have is that we're currently not tracking what needs/uses plasma_engine_geolocation dataengine.

Comment 8 Kevin Kofler 2015-09-11 16:13:04 UTC
Right, the problem is that the data engine is not used by linking directly to libplasma-geolocation-interface.so, but through the plugin, so RPM does not autodetect the dependency.

For Plasma 4, we had some code that I wrote to track data engine dependencies, but the code still needs to be ported to or rewritten for Plasma 5.

Comment 9 Ian Pilcher 2015-09-11 19:24:51 UTC
(In reply to Rex Dieter from comment #7)
> I guess one concern I have is that we're currently not tracking what
> needs/uses plasma_engine_geolocation dataengine.

I hope this doesn't mean that it's simply impossible to ever make a packaging change that affects a Plasma data engine.

Comment 10 Rex Dieter 2015-09-11 19:28:05 UTC
certainly not impossible, but it's more work than just "shove everything into a subpkg" too.  this change may break something else.

Comment 11 Ian Pilcher 2015-09-11 21:13:30 UTC
(In reply to Rex Dieter from comment #10)
> certainly not impossible, but it's more work than just "shove everything
> into a subpkg" too.  this change may break something else.

If any change may break something, and there's no way to check whether a change will break something, and we're not allowed to break anything, then I'd say it's pretty close to effectively impossible.

Comment 12 Ian Pilcher 2015-09-11 23:18:52 UTC
(In reply to Ian Pilcher from comment #11)
> If any change may break something, and there's no way to check whether a
> change will break something, and we're not allowed to break anything, then
> I'd say it's pretty close to effectively impossible.

I realize that may come off as petulant.  What I'm really asking is what is the way forward?  I'm willing to do some work, but thus far I don't know what that work is.

Comment 13 Ian Pilcher 2015-09-22 14:18:49 UTC
> I realize that may come off as petulant.  What I'm really asking is what is
> the way forward?  I'm willing to do some work, but thus far I don't know
> what that work is.

Ping?  If that question is unanswerable, then I would have to say that this bug is effectively unfixable, and no changes that affect packaging of Plasma data engines can ever be made.

That would be unfortunate, to say the least.

Comment 14 Rex Dieter 2015-09-22 14:40:40 UTC
Sounds like no one has an answer for my concern about consumers for the geoip dataengine.  I guess we can just do it anyway, and see what (if anything) breaks.

Mind helping with coming up with a .spec patch to implement the split?

Comment 15 Rex Dieter 2015-09-22 14:43:56 UTC
And, dnf doesn't handle split package upgrade paths right (yet), see bug #1261034 , that may have to be treated as a blocker for implementing this too.

Comment 16 Ian Pilcher 2015-09-22 14:59:48 UTC
(In reply to Rex Dieter from comment #14)
> Sounds like no one has an answer for my concern about consumers for the
> geoip dataengine.  I guess we can just do it anyway, and see what (if
> anything) breaks.

FWIW, none of my efforts to turn up a dependency with ldd, strings, grepping .desktop files, etc., have found anything.

> Mind helping with coming up with a .spec patch to implement the split?

Not at all.  I've been waiting for the go-ahead to to so.

(In reply to Rex Dieter from comment #15)
> And, dnf doesn't handle split package upgrade paths right (yet), see bug
> #1261034 , that may have to be treated as a blocker for implementing this
> too.

That's just ... wow.

I don't think it's a show-stopper for this, however.  I was already planning to add "Recommends: plasma-workstace-geolocation" to the main package, which should produce the same effect in the default case.

Comment 17 Kevin Kofler 2015-09-22 15:56:47 UTC
> I realize that may come off as petulant.  What I'm really
> asking is what is the way forward?  I'm willing to do some
> work, but thus far I don't know what that work is.

Port my plasma-dataengine-depextractor and the plasma.prov and plasma.req RPM macro files to Plasma 5. (They were part of the Plasma PackageKit work, but in this case, the compile-time parts are what we need, not the run-time PackageKit ones.)


IMHO, doing this split as suggested is just a horrible idea. DNF won't let us get the upgrade path right, and we also have no way to track what we are going to break without auto-Requires.

Comment 18 Ian Pilcher 2015-09-22 20:02:35 UTC
Created attachment 1075996 [details]
SPEC file patch

Comment 19 Ian Pilcher 2015-09-22 20:15:56 UTC
(In reply to Kevin Kofler from comment #17)
> Port my plasma-dataengine-depextractor and the plasma.prov and plasma.req
> RPM macro files to Plasma 5. (They were part of the Plasma PackageKit work,
> but in this case, the compile-time parts are what we need, not the run-time
> PackageKit ones.)

I can't even find this with Google.  Even if I could, I'm reasonably certain that doing this is way beyond my skill level.

> IMHO, doing this split as suggested is just a horrible idea. DNF won't let
> us get the upgrade path right, and we also have no way to track what we are
> going to break without auto-Requires.

And I certainly can't fix DNF.

So basically never mind.  Should I close this as WONTFIX?

Comment 20 Rex Dieter 2015-09-22 20:29:32 UTC
The dnf-fails-to-handle-upgrade-paths bug is currently a f23 release blocker, so hopefully will be addressed soon.

Comment 21 Rex Dieter 2015-10-04 20:04:17 UTC
%changelog
* Sat Oct 03 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.2-2
- .spec cosmetics, use %%license
- -common, -drkonqi, -libs, libkworkspace5 subpkgs
- -geolocation subpkg (#1222097)
- -drkonqi: include installdbgsymbols.sh

Comment 22 Fedora Update System 2015-10-06 02:26:13 UTC
bluedevil-5.4.2-1.fc23 kde-cli-tools-5.4.2-1.fc23 kde-gtk-config-5.4.2-1.fc23 kdecoration-5.4.2-1.fc23 kdeplasma-addons-5.4.2-1.fc23 kf5-kwayland-5.4.2-1.fc23 kgamma-5.4.2-1.fc23 khelpcenter-5.4.2-1.fc23 khotkeys-5.4.2-1.fc23 kinfocenter-5.4.2-1.fc23 kmenuedit-5.4.2-1.fc23 kscreen-5.4.2-1.fc23 ksshaskpass-5.4.2-1.fc23 ksysguard-5.4.2-1.fc23 kwayland-integration-5.4.2-1.fc23 kwin-5.4.2-1.fc23 kwrited-5.4.2-1.fc23 libkscreen-qt5-5.4.2-1.fc23 libksysguard-5.4.2-1.fc23 muon-5.4.2-1.fc23 oxygen-fonts-5.4.2-1.fc23 pam-kwallet-5.4.2-1.fc23 plasma-breeze-5.4.2-1.fc23 plasma-desktop-5.4.2-2.fc23 plasma-milou-5.4.2-1.fc23 plasma-nm-5.4.2-1.fc23 plasma-oxygen-5.4.2-1.fc23 plasma-pa-5.4.2-1.fc23 plasma-sdk-5.4.2-1.fc23 plasma-systemsettings-5.4.2-1.fc23 plasma-workspace-5.4.2-4.fc23 plasma-workspace-wallpapers-5.4.2-1.fc23 polkit-kde-5.4.2-1.fc23 powerdevil-5.4.2-1.fc23 sddm-kcm-5.4.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-555ed68cfa

Comment 23 Fedora Update System 2015-10-06 02:35:23 UTC
bluedevil-5.4.2-1.fc22 kde-cli-tools-5.4.2-1.fc22 kde-gtk-config-5.4.2-1.fc22 kdecoration-5.4.2-1.fc22 kdeplasma-addons-5.4.2-1.fc22 kf5-kwayland-5.4.2-1.fc22 kgamma-5.4.2-1.fc22 khelpcenter-5.4.2-1.fc22 khotkeys-5.4.2-1.fc22 kinfocenter-5.4.2-1.fc22 kmenuedit-5.4.2-1.fc22 kscreen-5.4.2-1.fc22 ksshaskpass-5.4.2-1.fc22 ksysguard-5.4.2-1.fc22 kwayland-integration-5.4.2-1.fc22 kwin-5.4.2-1.fc22 kwrited-5.4.2-1.fc22 libkscreen-qt5-5.4.2-1.fc22 libksysguard-5.4.2-1.fc22 muon-5.4.2-1.fc22 oxygen-fonts-5.4.2-1.fc22 pam-kwallet-5.4.2-1.fc22 plasma-breeze-5.4.2-1.fc22 plasma-desktop-5.4.2-2.fc22 plasma-milou-5.4.2-1.fc22 plasma-nm-5.4.2-1.fc22 plasma-oxygen-5.4.2-1.fc22 plasma-pa-5.4.2-1.fc22 plasma-sdk-5.4.2-1.fc22 plasma-systemsettings-5.4.2-1.fc22 plasma-workspace-5.4.2-4.fc22 plasma-workspace-wallpapers-5.4.2-1.fc22 polkit-kde-5.4.2-1.fc22 powerdevil-5.4.2-1.fc22 sddm-kcm-5.4.2-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6b26456127

Comment 24 Fedora Update System 2015-10-06 02:57:03 UTC
bluedevil-5.4.2-1.fc22 kde-cli-tools-5.4.2-1.fc22 kde-gtk-config-5.4.2-1.fc22 kdecoration-5.4.2-1.fc22 kdeplasma-addons-5.4.2-1.fc22 kf5-kwayland-5.4.2-1.fc22 kgamma-5.4.2-1.fc22 khelpcenter-5.4.2-1.fc22 khotkeys-5.4.2-1.fc22 kinfocenter-5.4.2-1.fc22 kmenuedit-5.4.2-1.fc22 kscreen-5.4.2-1.fc22 ksshaskpass-5.4.2-1.fc22 ksysguard-5.4.2-1.fc22 kwayland-integration-5.4.2-1.fc22 kwin-5.4.2-1.fc22 kwrited-5.4.2-1.fc22 libkscreen-qt5-5.4.2-1.fc22 libksysguard-5.4.2-1.fc22 muon-5.4.2-1.fc22 oxygen-fonts-5.4.2-1.fc22 pam-kwallet-5.4.2-1.fc22 plasma-breeze-5.4.2-1.fc22 plasma-desktop-5.4.2-2.fc22 plasma-milou-5.4.2-1.fc22 plasma-nm-5.4.2-1.fc22 plasma-oxygen-5.4.2-1.fc22 plasma-pa-5.4.2-1.fc22 plasma-sdk-5.4.2-1.fc22 plasma-systemsettings-5.4.2-1.fc22 plasma-workspace-5.4.2-4.fc22 plasma-workspace-wallpapers-5.4.2-1.fc22 polkit-kde-5.4.2-1.fc22 powerdevil-5.4.2-1.fc22 sddm-kcm-5.4.2-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6b26456127

Comment 25 Fedora Update System 2015-10-07 16:26:50 UTC
bluedevil-5.4.2-1.fc22, kde-cli-tools-5.4.2-1.fc22, kde-gtk-config-5.4.2-1.fc22, kdecoration-5.4.2-1.fc22, kdeplasma-addons-5.4.2-1.fc22, kf5-kwayland-5.4.2-1.fc22, kgamma-5.4.2-1.fc22, khelpcenter-5.4.2-1.fc22, khotkeys-5.4.2-1.fc22, kinfocenter-5.4.2-1.fc22, kmenuedit-5.4.2-1.fc22, kscreen-5.4.2-1.fc22, ksshaskpass-5.4.2-1.fc22, ksysguard-5.4.2-1.fc22, kwayland-integration-5.4.2-1.fc22, kwin-5.4.2-1.fc22, kwrited-5.4.2-1.fc22, libkscreen-qt5-5.4.2-1.fc22, libksysguard-5.4.2-1.fc22, muon-5.4.2-1.fc22, oxygen-fonts-5.4.2-1.fc22, pam-kwallet-5.4.2-1.fc22, plasma-breeze-5.4.2-1.fc22, plasma-desktop-5.4.2-2.fc22, plasma-milou-5.4.2-1.fc22, plasma-nm-5.4.2-1.fc22, plasma-oxygen-5.4.2-1.fc22, plasma-pa-5.4.2-1.fc22, plasma-sdk-5.4.2-1.fc22, plasma-systemsettings-5.4.2-1.fc22, plasma-workspace-5.4.2-4.fc22, plasma-workspace-wallpapers-5.4.2-1.fc22, polkit-kde-5.4.2-1.fc22, powerdevil-5.4.2-1.fc22, sddm-kcm-5.4.2-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update plasma-workspace plasma-desktop sddm-kcm powerdevil polkit-kde plasma-workspace-wallpapers plasma-systemsettings plasma-sdk plasma-pa plasma-oxygen plasma-nm plasma-milou plasma-breeze pam-kwallet oxygen-fonts muon libksysguard libkscreen-qt5 kwrited kwin kwayland-integration ksysguard ksshaskpass kscreen kmenuedit kinfocenter khotkeys khelpcenter kgamma kf5-kwayland kdeplasma-addons kdecoration kde-gtk-config kde-cli-tools bluedevil'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6b26456127

Comment 26 Fedora Update System 2015-10-07 16:28:44 UTC
bluedevil-5.4.2-1.fc23, kde-cli-tools-5.4.2-1.fc23, kde-gtk-config-5.4.2-1.fc23, kdecoration-5.4.2-1.fc23, kdeplasma-addons-5.4.2-1.fc23, kf5-kwayland-5.4.2-1.fc23, kgamma-5.4.2-1.fc23, khelpcenter-5.4.2-1.fc23, khotkeys-5.4.2-1.fc23, kinfocenter-5.4.2-1.fc23, kmenuedit-5.4.2-1.fc23, kscreen-5.4.2-1.fc23, ksshaskpass-5.4.2-1.fc23, ksysguard-5.4.2-1.fc23, kwayland-integration-5.4.2-1.fc23, kwin-5.4.2-1.fc23, kwrited-5.4.2-1.fc23, libkscreen-qt5-5.4.2-1.fc23, libksysguard-5.4.2-1.fc23, muon-5.4.2-1.fc23, oxygen-fonts-5.4.2-1.fc23, pam-kwallet-5.4.2-1.fc23, plasma-breeze-5.4.2-1.fc23, plasma-desktop-5.4.2-2.fc23, plasma-milou-5.4.2-1.fc23, plasma-nm-5.4.2-1.fc23, plasma-oxygen-5.4.2-1.fc23, plasma-pa-5.4.2-1.fc23, plasma-sdk-5.4.2-1.fc23, plasma-systemsettings-5.4.2-1.fc23, plasma-workspace-5.4.2-4.fc23, plasma-workspace-wallpapers-5.4.2-1.fc23, polkit-kde-5.4.2-1.fc23, powerdevil-5.4.2-1.fc23, sddm-kcm-5.4.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update plasma-workspace plasma-desktop sddm-kcm powerdevil polkit-kde plasma-workspace-wallpapers plasma-systemsettings plasma-sdk plasma-pa plasma-oxygen plasma-nm plasma-milou plasma-breeze pam-kwallet oxygen-fonts muon libksysguard libkscreen-qt5 kwrited kwin kwayland-integration ksysguard ksshaskpass kscreen kmenuedit kinfocenter khotkeys khelpcenter kgamma kf5-kwayland kdeplasma-addons kdecoration kde-gtk-config kde-cli-tools bluedevil'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-555ed68cfa

Comment 27 Fedora Update System 2015-10-08 10:33:33 UTC
bluedevil-5.4.2-1.fc23, kde-cli-tools-5.4.2-1.fc23, kde-gtk-config-5.4.2-1.fc23, kdecoration-5.4.2-1.fc23, kdeplasma-addons-5.4.2-1.fc23, kf5-kwayland-5.4.2-1.fc23, kgamma-5.4.2-1.fc23, khelpcenter-5.4.2-1.fc23, khotkeys-5.4.2-1.fc23, kinfocenter-5.4.2-1.fc23, kmenuedit-5.4.2-1.fc23, kscreen-5.4.2-1.fc23, ksshaskpass-5.4.2-1.fc23, ksysguard-5.4.2-1.fc23, kwayland-integration-5.4.2-1.fc23, kwin-5.4.2-1.fc23, kwrited-5.4.2-1.fc23, libkscreen-qt5-5.4.2-1.fc23, libksysguard-5.4.2-1.fc23, muon-5.4.2-1.fc23, oxygen-fonts-5.4.2-1.fc23, pam-kwallet-5.4.2-1.fc23, plasma-breeze-5.4.2-1.fc23, plasma-desktop-5.4.2-2.fc23, plasma-milou-5.4.2-1.fc23, plasma-nm-5.4.2-1.fc23, plasma-oxygen-5.4.2-1.fc23, plasma-pa-5.4.2-1.fc23, plasma-sdk-5.4.2-1.fc23, plasma-systemsettings-5.4.2-1.fc23, plasma-workspace-5.4.2-4.fc23, plasma-workspace-wallpapers-5.4.2-1.fc23, polkit-kde-5.4.2-1.fc23, powerdevil-5.4.2-1.fc23, sddm-kcm-5.4.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2015-10-13 11:43:38 UTC
bluedevil-5.4.2-1.fc22 kde-cli-tools-5.4.2-1.fc22 kde-gtk-config-5.4.2-1.fc22 kdecoration-5.4.2-1.fc22 kdeplasma-addons-5.4.2-1.fc22 kf5-kwayland-5.4.2-1.fc22 kgamma-5.4.2-1.fc22 khelpcenter-5.4.2-1.fc22 khotkeys-5.4.2-1.fc22 kinfocenter-5.4.2-1.fc22 kmenuedit-5.4.2-1.fc22 kscreen-5.4.2-1.fc22 ksshaskpass-5.4.2-1.fc22 ksysguard-5.4.2-1.fc22 kwayland-integration-5.4.2-1.fc22 kwin-5.4.2-1.fc22 kwrited-5.4.2-1.fc22 libkscreen-qt5-5.4.2-1.fc22 libksysguard-5.4.2-1.fc22 muon-5.4.2-1.fc22 oxygen-fonts-5.4.2-1.fc22 pam-kwallet-5.4.2-1.fc22 plasma-breeze-5.4.2-2.fc22 plasma-desktop-5.4.2-2.fc22 plasma-milou-5.4.2-1.fc22 plasma-nm-5.4.2-1.fc22 plasma-oxygen-5.4.2-1.fc22 plasma-pa-5.4.2-1.fc22 plasma-sdk-5.4.2-1.fc22 plasma-systemsettings-5.4.2-1.fc22 plasma-workspace-5.4.2-4.fc22 plasma-workspace-wallpapers-5.4.2-1.fc22 polkit-kde-5.4.2-1.fc22 powerdevil-5.4.2-1.fc22 sddm-kcm-5.4.2-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6b26456127

Comment 29 Fedora Update System 2015-10-14 09:28:00 UTC
bluedevil-5.4.2-1.fc22, kde-cli-tools-5.4.2-1.fc22, kde-gtk-config-5.4.2-1.fc22, kdecoration-5.4.2-1.fc22, kdeplasma-addons-5.4.2-1.fc22, kf5-kwayland-5.4.2-1.fc22, kgamma-5.4.2-1.fc22, khelpcenter-5.4.2-1.fc22, khotkeys-5.4.2-1.fc22, kinfocenter-5.4.2-1.fc22, kmenuedit-5.4.2-1.fc22, kscreen-5.4.2-1.fc22, ksshaskpass-5.4.2-1.fc22, ksysguard-5.4.2-1.fc22, kwayland-integration-5.4.2-1.fc22, kwin-5.4.2-1.fc22, kwrited-5.4.2-1.fc22, libkscreen-qt5-5.4.2-1.fc22, libksysguard-5.4.2-1.fc22, muon-5.4.2-1.fc22, oxygen-fonts-5.4.2-1.fc22, pam-kwallet-5.4.2-1.fc22, plasma-breeze-5.4.2-2.fc22, plasma-desktop-5.4.2-2.fc22, plasma-milou-5.4.2-1.fc22, plasma-nm-5.4.2-1.fc22, plasma-oxygen-5.4.2-1.fc22, plasma-pa-5.4.2-1.fc22, plasma-sdk-5.4.2-1.fc22, plasma-systemsettings-5.4.2-1.fc22, plasma-workspace-5.4.2-4.fc22, plasma-workspace-wallpapers-5.4.2-1.fc22, polkit-kde-5.4.2-1.fc22, powerdevil-5.4.2-1.fc22, sddm-kcm-5.4.2-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update plasma-breeze plasma-workspace sddm-kcm plasma-systemsettings muon kdecoration kde-gtk-config libksysguard kde-cli-tools bluedevil plasma-sdk libkscreen-qt5 kwrited powerdevil plasma-pa kwin kwayland-integration plasma-oxygen ksysguard ksshaskpass plasma-desktop polkit-kde plasma-nm kscreen kmenuedit plasma-milou kinfocenter khotkeys plasma-workspace-wallpapers pam-kwallet khelpcenter kgamma oxygen-fonts kf5-kwayland kdeplasma-addons'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6b26456127

Comment 30 Fedora Update System 2015-10-23 17:25:49 UTC
bluedevil-5.4.2-1.fc22, kde-cli-tools-5.4.2-1.fc22, kde-gtk-config-5.4.2-1.fc22, kdecoration-5.4.2-1.fc22, kdeplasma-addons-5.4.2-1.fc22, kf5-kwayland-5.4.2-1.fc22, kgamma-5.4.2-1.fc22, khelpcenter-5.4.2-1.fc22, khotkeys-5.4.2-1.fc22, kinfocenter-5.4.2-1.fc22, kmenuedit-5.4.2-1.fc22, kscreen-5.4.2-1.fc22, ksshaskpass-5.4.2-1.fc22, ksysguard-5.4.2-1.fc22, kwayland-integration-5.4.2-1.fc22, kwin-5.4.2-1.fc22, kwrited-5.4.2-1.fc22, libkscreen-qt5-5.4.2-1.fc22, libksysguard-5.4.2-1.fc22, muon-5.4.2-1.fc22, oxygen-fonts-5.4.2-1.fc22, pam-kwallet-5.4.2-1.fc22, plasma-breeze-5.4.2-2.fc22, plasma-desktop-5.4.2-2.fc22, plasma-milou-5.4.2-1.fc22, plasma-nm-5.4.2-1.fc22, plasma-oxygen-5.4.2-1.fc22, plasma-pa-5.4.2-1.fc22, plasma-sdk-5.4.2-1.fc22, plasma-systemsettings-5.4.2-1.fc22, plasma-workspace-5.4.2-4.fc22, plasma-workspace-wallpapers-5.4.2-1.fc22, polkit-kde-5.4.2-1.fc22, powerdevil-5.4.2-1.fc22, sddm-kcm-5.4.2-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 nucleo 2016-05-01 13:05:15 UTC
After update plasma-workspace-5.6.3-3.fc25 was installed NetworkManager and plasma-workspace-geolocation, both can't be removed anymore because plasma-workspace-libs-5.6.3-3.fc25 requires plasma-workspace-geolocation
http://koji.fedoraproject.org/koji/rpminfo?rpmID=7644103

plasma-workspace-libs-5.6.3-2.fc25 was without such hard dependency 
http://koji.fedoraproject.org/koji/rpminfo?rpmID=7633257

Comment 32 nucleo 2016-05-01 13:13:41 UTC
My mistake http://koji.fedoraproject.org/koji/rpminfo?rpmID=7633262 also requires plasma-workspace-geolocation = 5.6.3-2.fc25

If I try to remove NetworkManager then dnf removes plasma-desktop and plasma-workspace

# dnf remove NetworkManager
cachedir: /var/cache/dnf
Loaded plugins: copr, playground, generate_completion_cache, noroot, builddep, protected_packages, Query, download, config-manager, needs-restarting, reposync, debuginfo-install
DNF version: 1.1.8
--> Starting dependency resolution
--> Finding unneeded leftover dependencies
---> Package NetworkManager.i686 1:1.2.0-1.fc25 will be erased
---> Package NetworkManager-libnm.i686 1:1.2.0-1.fc25 will be erased
---> Package f23-kde-theme.noarch 23.0-6.fc24 will be erased
---> Package f24-kde-theme.noarch 24.2-1.fc25 will be erased
---> Package f24-kde-theme-core.i686 5.6.3-3.fc25 will be erased
---> Package kdeplasma-addons.i686 5.6.3-1.fc25 will be erased
---> Package kf5-kactivities-stats.i686 5.21.0-2.fc25 will be erased
---> Package kf5-kpeople.i686 5.21.0-1.fc25 will be erased
---> Package kf5-networkmanager-qt.i686 5.21.0-1.fc25 will be erased
---> Package libndp.i686 1.5-3.fc24 will be erased
---> Package plasma-desktop.i686 5.6.3-2.fc25 will be erased
---> Package plasma-integration.i686 5.6.3-1.fc25 will be erased
---> Package plasma-workspace.i686 5.6.3-3.fc25 will be erased
---> Package plasma-workspace-drkonqi.i686 5.6.3-3.fc25 will be erased
---> Package plasma-workspace-geolocation.i686 5.6.3-3.fc25 will be erased
---> Package plasma-workspace-geolocation-libs.i686 5.6.3-3.fc25 will be erased
---> Package plasma-workspace-libs.i686 5.6.3-3.fc25 will be erased
---> Package sddm-breeze.noarch 5.6.3-3.fc25 will be erased
--> Finished dependency resolution
Dependencies resolved.
=======================================================================================================
 Package                                  Arch          Version                  Repository       Size
=======================================================================================================
Removing:
 NetworkManager                           i686          1:1.2.0-1.fc25           @rawhide         10 M
 NetworkManager-libnm                     i686          1:1.2.0-1.fc25           @rawhide        1.7 M
 f23-kde-theme                            noarch        23.0-6.fc24              @rawhide        4.4 M
 f24-kde-theme                            noarch        24.2-1.fc25              @System         2.4 M
 f24-kde-theme-core                       i686          5.6.3-3.fc25             @rawhide        166 k
 kdeplasma-addons                         i686          5.6.3-1.fc25             @System         7.7 M
 kf5-kactivities-stats                    i686          5.21.0-2.fc25            @rawhide        314 k
 kf5-kpeople                              i686          5.21.0-1.fc25            @rawhide        464 k
 kf5-networkmanager-qt                    i686          5.21.0-1.fc25            @rawhide        1.5 M
 libndp                                   i686          1.5-3.fc24               @rawhide         63 k
 plasma-desktop                           i686          5.6.3-2.fc25             @rawhide         28 M
 plasma-integration                       i686          5.6.3-1.fc25             @System         311 k
 plasma-workspace                         i686          5.6.3-3.fc25             @rawhide         24 M
 plasma-workspace-drkonqi                 i686          5.6.3-3.fc25             @rawhide        4.8 M
 plasma-workspace-geolocation             i686          5.6.3-3.fc25             @rawhide        167 k
 plasma-workspace-geolocation-libs        i686          5.6.3-3.fc25             @rawhide         39 k
 plasma-workspace-libs                    i686          5.6.3-3.fc25             @rawhide        5.6 M
 sddm-breeze                              noarch        5.6.3-3.fc25             @rawhide        957 k

Transaction Summary
=======================================================================================================
Remove  18 Packages

Installed size: 93 M

Comment 33 Rex Dieter 2016-05-01 21:01:00 UTC
temporary issue in plasma-workspace-5.6.3-3 build, should be fixed in -4

Comment 34 nucleo 2016-06-28 19:59:04 UTC
NetworkManager again can't be removed in Rawhide:

# dnf remove NetworkManager
cachedir: /var/cache/dnf
Loaded plugins: builddep, config-manager, debuginfo-install, reposync, download, copr, generate_completion_cache, Query, needs-restarting, noroot, playground, protected_packages
DNF version: 1.1.9
--> Starting dependency resolution
--> Finding unneeded leftover dependencies
---> Package NetworkManager.i686 1:1.2.2-2.fc25 will be erased
---> Package NetworkManager-libnm.i686 1:1.2.2-2.fc25 will be erased
---> Package bluez.i686 5.40-1.fc25 will be erased
---> Package f24-kde-theme.noarch 24.5-1.fc25 will be erased
---> Package f24-kde-theme-core.i686 5.6.95-3.fc25 will be erased
---> Package kf5-bluez-qt.i686 5.23.0-1.fc25 will be erased
---> Package kf5-kactivities-stats.i686 5.23.0-1.fc25 will be erased
---> Package kf5-kpeople.i686 5.23.0-1.fc25 will be erased
---> Package kf5-networkmanager-qt.i686 5.23.0-1.fc25 will be erased
---> Package libndp.i686 1.6-1.fc25 will be erased
---> Package plasma-desktop.i686 5.6.95-1.fc25 will be erased
---> Package plasma-integration.i686 5.6.95-1.fc25 will be erased
---> Package plasma-workspace.i686 5.6.95-3.fc25 will be erased
---> Package plasma-workspace-drkonqi.i686 5.6.95-3.fc25 will be erased
---> Package powerdevil.i686 5.6.95-1.fc25 will be erased
---> Package sddm-breeze.noarch 5.6.95-3.fc25 will be erased
--> Finished dependency resolution
Dependencies resolved.
=======================================================================================================
 Package                            Arch             Version                  Repository          Size
=======================================================================================================
Removing:
 NetworkManager                     i686             1:1.2.2-2.fc25           @rawhide            10 M
 NetworkManager-libnm               i686             1:1.2.2-2.fc25           @rawhide           1.7 M
 bluez                              i686             5.40-1.fc25              @rawhide           3.9 M
 f24-kde-theme                      noarch           24.5-1.fc25              @rawhide           2.4 M
 f24-kde-theme-core                 i686             5.6.95-3.fc25            @rawhide           125 k
 kf5-bluez-qt                       i686             5.23.0-1.fc25            @rawhide           708 k
 kf5-kactivities-stats              i686             5.23.0-1.fc25            @rawhide           302 k
 kf5-kpeople                        i686             5.23.0-1.fc25            @rawhide           441 k
 kf5-networkmanager-qt              i686             5.23.0-1.fc25            @rawhide           1.4 M
 libndp                             i686             1.6-1.fc25               @rawhide            67 k
 plasma-desktop                     i686             5.6.95-1.fc25            @rawhide            26 M
 plasma-integration                 i686             5.6.95-1.fc25            @rawhide           300 k
 plasma-workspace                   i686             5.6.95-3.fc25            @rawhide            19 M
 plasma-workspace-drkonqi           i686             5.6.95-3.fc25            @rawhide           4.8 M
 powerdevil                         i686             5.6.95-1.fc25            @rawhide           2.0 M
 sddm-breeze                        noarch           5.6.95-3.fc25            @rawhide           685 k

Transaction Summary
=======================================================================================================
Remove  16 Packages



# rpm -e kf5-networkmanager-qt
error: Failed dependencies:
        libKF5NetworkManagerQt.so.6 is needed by (installed) powerdevil-5.6.95-1.fc25.i686

Comment 35 Rex Dieter 2016-06-28 21:42:45 UTC
Looks like we'll have to drop the hard 
Requires: NetworkManager
dep in kf5-networkmanager-qt , similar to how we dropped
Requires: PackageKit
from PackageKit-Qt awhile back

Comment 36 Rex Dieter 2016-06-28 21:55:26 UTC
opened separate bug to track this proposal, see bug #1350973


Note You need to log in before you can comment on or make changes to this bug.