Bug 1222238 - features/changelog: buffer overrun in changelog-helpers
Summary: features/changelog: buffer overrun in changelog-helpers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1252057
TreeView+ depends on / blocked
 
Reported: 2015-05-16 19:47 UTC by Prasanna Kumar Kalever
Modified: 2016-06-16 13:03 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1252057 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:03:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2015-05-16 19:47:25 UTC
Description of problem:
features/changelog:  buffer overrun in changelog-helpers 

                                                                                 
changelog-helpers.c:1911:17: warning: Size argument is greater than the free   space in the destination buffer strncat (result, pre_dir_name,PATH_MAX);        
                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~         
                                                                                 
changelog-helpers.c:1919:17: warning: Size argument is greater than the free   space in the destination buffer strncat (result, bname,PATH_MAX);               
                                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                



Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-16 19:51:07 UTC
REVIEW: http://review.gluster.org/10802 (features/changelog: fix buffer overrun in changelog-helpers) posted (#1) for review on master by Prasanna Kumar Kalever

Comment 2 Anand Avati 2015-05-22 06:37:09 UTC
REVIEW: http://review.gluster.org/10802 (features/changelog: fix buffer overrun in changelog-helpers) posted (#2) for review on master by Prasanna Kumar Kalever

Comment 3 Anand Avati 2015-07-15 05:04:32 UTC
COMMIT: http://review.gluster.org/10802 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 09530dfd822c8c3cc8da20a4600b5d2aec1ebf9d
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Sun May 17 00:26:06 2015 +0530

    features/changelog: fix buffer overrun in changelog-helpers
    
    changelog-helpers.c:1911:17: warning: Size argument is greater than the free
    space in the destination buffer strncat (result, pre_dir_name, PATH_MAX);
                                    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    changelog-helpers.c:1919:17: warning: Size argument is greater than the free
    space in the destination buffer strncat (result, bname, PATH_MAX);
                                    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    Change-Id: I60ca7fe762f07cb72fe7b69f0253835becaff7b9
    BUG: 1222238
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/10802
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 4 Mike McCune 2016-03-28 23:22:56 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 5 Niels de Vos 2016-06-16 13:03:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.