Bug 1252057 - features/changelog: buffer overrun in changelog-helpers
features/changelog: buffer overrun in changelog-helpers
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.6
All All
urgent Severity urgent
: ---
: ---
Assigned To: Prasanna Kumar Kalever
: Triaged
Depends On: 1222238
Blocks: glusterfs-3.7.7
  Show dependency treegraph
 
Reported: 2015-08-10 10:56 EDT by Kaleb KEITHLEY
Modified: 2016-03-22 04:14 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1222238
Environment:
Last Closed: 2016-03-22 04:14:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-08-10 10:56:34 EDT
+++ This bug was initially created as a clone of Bug #1222238 +++

Description of problem:
features/changelog:  buffer overrun in changelog-helpers 

                                                                                 
changelog-helpers.c:1911:17: warning: Size argument is greater than the free   space in the destination buffer strncat (result, pre_dir_name,PATH_MAX);        
                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~         
                                                                                 
changelog-helpers.c:1919:17: warning: Size argument is greater than the free   space in the destination buffer strncat (result, bname,PATH_MAX);               
                                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                



Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-05-16 15:51:07 EDT ---

REVIEW: http://review.gluster.org/10802 (features/changelog: fix buffer overrun in changelog-helpers) posted (#1) for review on master by Prasanna Kumar Kalever

--- Additional comment from Anand Avati on 2015-05-22 02:37:09 EDT ---

REVIEW: http://review.gluster.org/10802 (features/changelog: fix buffer overrun in changelog-helpers) posted (#2) for review on master by Prasanna Kumar Kalever

--- Additional comment from Anand Avati on 2015-07-15 01:04:32 EDT ---

COMMIT: http://review.gluster.org/10802 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 09530dfd822c8c3cc8da20a4600b5d2aec1ebf9d
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Sun May 17 00:26:06 2015 +0530

    features/changelog: fix buffer overrun in changelog-helpers
    
    changelog-helpers.c:1911:17: warning: Size argument is greater than the free
    space in the destination buffer strncat (result, pre_dir_name, PATH_MAX);
                                    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    changelog-helpers.c:1919:17: warning: Size argument is greater than the free
    space in the destination buffer strncat (result, bname, PATH_MAX);
                                    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    Change-Id: I60ca7fe762f07cb72fe7b69f0253835becaff7b9
    BUG: 1222238
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/10802
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 1 Kaleb KEITHLEY 2015-08-10 11:00:12 EDT
While experimenting with using OpenSuse Build Service (OBS) to build community gluster packages for 3.7.3, discovered that OBS will fail the overall build due to these warnings. (Despite running to completion and even creating the RPMs.)
Comment 2 Kaushal 2015-10-28 08:28:38 EDT
This bug could not be fixed in time for glusterfs-3.7.4 or glusterfs-3.7.5. This is now being tracked for being fixed in glusterfs-3.7.6.
Comment 3 Raghavendra Talur 2015-11-08 15:24:17 EST
This bug could not be fixed in time for glusterfs-3.7.6.
This is now being tracked for being fixed in glusterfs-3.7.7.
Comment 4 Prasanna Kumar Kalever 2015-11-09 07:56:42 EST
Already Merged:
http://review.gluster.org/#/c/12494/

Note You need to log in before you can comment on or make changes to this bug.