Bug 122227 - console9x15 out of sync with 9x15
console9x15 out of sync with 9x15
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bitmap-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 07:03 EDT by Daniel Yacob
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: -0.3-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 05:35:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Yacob 2004-05-02 07:03:44 EDT
Description of problem:

The Ethiopic glyphs in the console9x15.pcf font appear to be direct
copies from an older version 9x15.bdf.  At some point the 9x15 font
was updated and console9x15 was not.  So console9x15 contains bugs for
a few glyphs from the older 9x15.

Also, since it is a source rpm, bdf fonts should be included in the
fixfont.tar.bz2 found in the rpm.  Only the compiled versions (.pcf)
are provided.


Version-Release number of selected component (if applicable):

bitmap-fonts-0.3-2.src.rpm is the latest rpm that I can find.


How reproducible:

100%, every time the font is used.

Steps to Reproduce:
1.use the font in a gnometerm
2.select the Amharic IM
3.type n


Actual results:

U+1295 looks like U+1285, 12DD has one pixel too many.


Expected results:

U+1295 should look like U+1295.


Additional info:

I'm quite willing to fix the broken glyphs, I need only the source
file, the console9x15.bdf -which was not included in the source rpm!
Comment 1 Owen Taylor 2004-09-02 15:27:16 EDT
The console9x15.pcf comes from the 'konsole' distribution. (Part
of kde-core, if I recall.) I'm not sure if they had a .bdf file
either, but you can check there.

fontforge can certainly read in a .pcf file and write out a .bdf file.
Comment 2 Caolan McNamara 2005-11-09 05:35:47 EST
console9x15.pcf now built from 9x15.bdf updated from latest kde konsole 3.5

Note You need to log in before you can comment on or make changes to this bug.