Bug 1222445 - mutter indicates the wrong settings for Natural scrolling and loses changes between logins.
Summary: mutter indicates the wrong settings for Natural scrolling and loses changes b...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-18 08:54 UTC by Rodd Clarkson
Modified: 2015-05-18 23:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-18 23:16:57 UTC


Attachments (Terms of Use)

Description Rodd Clarkson 2015-05-18 08:54:01 UTC
Description of problem:

This is a follow up to bug #1206961

When I log in natural scrolling on my trackpad doesn't work.  However, the Mouse and Trackpad settings indicate it is active.  If you turn it off and then on again, then Natural scrolling works.

Regardless, these settings changes are lost when you log out and you need to reenable them on login again.



Version-Release number of selected component (if applicable):

mutter-3.16.2-1.fc22


How reproducible:

Each login


Steps to Reproduce:
1. Log in.
2. Open a web browser and go to a page that can be scrolled
3. Using two fingers on the trackpad, scroll up and down.  Natural scrolling isn't active.
4. Open Settings > Mouse and Trackpad and deselect Natural Scrolling.  Test again and you'll find natural scrolling is still not active.
5. Select Natural Scrolling again and natural scrolling now works.
6. Log out and in again and retest natural scrolling and it isn't active.

Actual results:

Natural scrolling settings aren't remembered across settings and aren't indicated correctly in the settings.

Expected results:

Natural scrolling should be remembered across settings and the settings should correctly identify the state.

Comment 1 Rui Matos 2015-05-18 12:28:51 UTC
Another one I can't reproduce... Have you completely rebooted at least once? Can you reproduce this consistently?

Immediately after you login, open just a terminal and get us the following outputs:

$ gsettings list-recursively org.gnome.desktop.peripherals.touchpad

$ xinput list-props <your touchpad id nr.>

Comment 2 Rodd Clarkson 2015-05-18 23:16:57 UTC
Hmmm, I'm pretty sure I rebooted and logged in and out a few times, but it all seems good now.  I did install the lasted updates before restarting this morning and libinput was updated, so maybe...

Anyhow, here's the information you requested but I'll close this bug as it appears to not be a problem (anymore).


$ gsettings list-recursively org.gnome.desktop.peripherals.touchpad
org.gnome.desktop.peripherals.touchpad natural-scroll true
org.gnome.desktop.peripherals.touchpad click-method 'default'
org.gnome.desktop.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad send-events 'enabled'
org.gnome.desktop.peripherals.touchpad tap-to-click true
org.gnome.desktop.peripherals.touchpad speed -0.094170403587443996


$ xinput list-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (273):	1
	libinput Tapping Enabled Default (274):	0
	libinput Accel Speed (275):	-0.094170
	libinput Accel Speed Default (276):	0.000000
	libinput Natural Scrolling Enabled (277):	1
	libinput Natural Scrolling Enabled Default (278):	0
	libinput Send Events Modes Available (254):	1, 1
	libinput Send Events Mode Enabled (255):	0, 0
	libinput Send Events Mode Enabled Default (256):	0, 0
	libinput Left Handed Enabled (279):	0
	libinput Left Handed Enabled Default (280):	0
	libinput Scroll Methods Available (281):	1, 0, 0
	libinput Scroll Method Enabled (282):	1, 0, 0
	libinput Scroll Method Enabled Default (283):	1, 0, 0
	libinput Click Methods Available (284):	1, 1
	libinput Click Method Enabled (285):	1, 0
	libinput Click Method Enabled Default (286):	1, 0
	Device Node (257):	"/dev/input/event12"
	Device Product ID (258):	1739, 10036


Note You need to log in before you can comment on or make changes to this bug.