Bug 1222737 - krunner crashes and will not restart after 5.3.0-5
Summary: krunner crashes and will not restart after 5.3.0-5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1223080 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-19 03:08 UTC by Gerald Cox
Modified: 2015-06-04 20:20 UTC (History)
11 users (show)

Fixed In Version: f22-kde-theme-22.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-04 20:20:12 UTC


Attachments (Terms of Use)
krunner crash notification (31.85 KB, image/png)
2015-05-19 03:11 UTC, Gerald Cox
no flags Details
Backtrace of krunner. (1.65 KB, text/plain)
2015-05-19 16:23 UTC, David Koppelman
no flags Details

Description Gerald Cox 2015-05-19 03:08:33 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gerald Cox 2015-05-19 03:11:11 UTC
Created attachment 1026943 [details]
krunner crash notification

Comment 2 Gerald Cox 2015-05-19 03:13:25 UTC
Description of problem: 
krunner crashes after plasma-workspace-5.3.0-5;
dnf downgrade to previous version resolves issue


Version-Release number of selected component (if applicable):
5.3.0-5

How reproducible:
Apply 5.3.0-5


Actual results:
krunner crashes, will not restart, cannot logoff via system menu


Expected results:
normal operation

Comment 3 Jan Grulich 2015-05-19 06:40:33 UTC
Did you update also f22-kde-theme or just plasma-workspace?

Comment 4 Daniel Vrátil 2015-05-19 08:51:17 UTC
Could you also get a  backtrace of the crash please (it is in the "Developer tab" in DrKonqi). You might need to install debug symbols first (dnf debuginfo-install plasma-workspace).

Comment 5 Rex Dieter 2015-05-19 12:25:34 UTC
rpm -q f22-kde-theme

please.

You want the one from the batched update:
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-workspace-5.3.0-5.fc22,f22-kde-theme-22.1-1.fc22


Jan, plasma-workspace probably should add a versioned dependency
Requires: f22-kde-theme >= 22.1

Comment 6 Fedora Update System 2015-05-19 15:30:51 UTC
plasma-workspace-5.3.0-6.fc22, f22-kde-theme-22.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-workspace-5.3.0-6.fc22,f22-kde-theme-22.3-1.fc22

Comment 7 David Koppelman 2015-05-19 16:21:58 UTC
I'm also experiencing this bug, I have both kde theme 22.1-1 and plasma workspace 5.3.0-5. I'll attach a backtrace from krunner.

Comment 8 David Koppelman 2015-05-19 16:23:58 UTC
Created attachment 1027301 [details]
Backtrace of krunner.

This obtained after logging into a non-root account. Only the crash notification window appeared--no desktop panels.

Comment 9 Gerald Cox 2015-05-19 16:38:18 UTC
(In reply to Rex Dieter from comment #5)
> rpm -q f22-kde-theme
> 
> please.
> 
> You want the one from the batched update:
> https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-workspace-5.
> 3.0-5.fc22,f22-kde-theme-22.1-1.fc22
> 
> 
> Jan, plasma-workspace probably should add a versioned dependency
> Requires: f22-kde-theme >= 22.1

The following is installed:
f22-kde-theme-22.1-1.fc22.noarch

If I'm reading your comment correctly, that wasn't causing the problem in my case.

Comment 10 Gerald Cox 2015-05-19 16:39:40 UTC
(In reply to Jan Grulich from comment #3)
> Did you update also f22-kde-theme or just plasma-workspace?

I just issued the dnf upgrade command.  See comment #9 - doesn't appear
that the f22-kde-theme requisite was causing the issue in my case.

Comment 11 Gerald Cox 2015-05-19 16:44:40 UTC
(In reply to Daniel Vrátil from comment #4)
> Could you also get a  backtrace of the crash please (it is in the "Developer
> tab" in DrKonqi). You might need to install debug symbols first (dnf
> debuginfo-install plasma-workspace).

Thanks I'll do that prior to the next test candidate.  A trace was provided in comment #8 (Thanks koppel@ece.lsu.edu).

Comment 12 Jan Grulich 2015-05-19 18:44:52 UTC
*** Bug 1223080 has been marked as a duplicate of this bug. ***

Comment 13 Gerald Cox 2015-05-19 22:00:42 UTC
Update ~.6 does not resolve issue.  Left negative feedback on Bohdi.  Appears that f22-kde-theme-3 now causes issue with system tray... applications no longer appear there.  When I backed out to f22-kde-theme-22.1-1.fc22.noarch system tray was restored to normal behavior.  Experienced severe screen lockups with workspace-3, additionally could not ssh into machine to use konsole or xterm; and behavior described above still there.  Backout to plasma-workspace-5.3.0-4.fc22.x86_64 resolved issue.

Comment 14 David Koppelman 2015-05-19 22:04:32 UTC
(In reply to Gerald Cox from comment #13)
> Experienced severe screen lockups with workspace-3, additionally
> could not ssh into machine to use konsole or xterm; and behavior described
> above still there.

In my case the only functioning UI was the crash reporter, but from there I could reach a shell. From the crash reporter start gdb, then issue the command "shell konsole" or your favorite shell.

Comment 15 Gerald Cox 2015-05-20 00:21:13 UTC
(In reply to David Koppelman from comment #14)
> (In reply to Gerald Cox from comment #13)
> 
> In my case the only functioning UI was the crash reporter, but from there I
> could reach a shell. From the crash reporter start gdb, then issue the
> command "shell konsole" or your favorite shell.

Yeah, for the ~.5 update I got the crash reporter, for the ~.6 update didn't even get that... I was lucky to be able to back it out...

Comment 16 Fedora Update System 2015-05-20 02:53:07 UTC
Package plasma-workspace-5.3.0-6.fc22, f22-kde-theme-22.3-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing plasma-workspace-5.3.0-6.fc22 f22-kde-theme-22.3-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-workspace-5.3.0-6.fc22,f22-kde-theme-22.3-1.fc22
then log in and leave karma (feedback).

Comment 17 Gerald Cox 2015-05-20 04:25:54 UTC
Please see my other comments here:
https://bugzilla.redhat.com/show_bug.cgi?id=1223159#c1

It appears the problem now my be related to some kind of fluke in the way the upgrade is being applied.  I was able to circumvent the problems by following
the steps in the above referenced comment.

Comment 18 David Koppelman 2015-05-20 14:32:27 UTC
I've had better luck. I applied the updates in the usual way and everything worked fine.

Comment 19 Gerald Cox 2015-05-20 17:07:22 UTC
(In reply to David Koppelman from comment #18)
> I've had better luck. I applied the updates in the usual way and everything
> worked fine.

Yes, looks like we've identified the cause of 1223159 and have a documented workaround for those who encounter it.

Comment 20 Fedora Update System 2015-05-22 02:32:18 UTC
Package f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing f22-kde-theme-22.3-1.fc22 plasma-desktop-5.3.0-6.fc22 plasma-workspace-5.3.0-8.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-desktop-5.3.0-6.fc22,plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22
then log in and leave karma (feedback).

Comment 21 Fedora Update System 2015-06-04 20:20:12 UTC
f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.