Bug 1223159 - Upgrade to 22.3-1 causes severe issues with status & notification
Summary: Upgrade to 22.3-1 causes severe issues with status & notification
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: f22-kde-theme
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-20 02:01 UTC by Gerald Cox
Modified: 2015-05-20 17:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-20 17:04:03 UTC
Type: Bug


Attachments (Terms of Use)
Normal status and notification area (67.08 KB, image/png)
2015-05-20 02:01 UTC, Gerald Cox
no flags Details

Description Gerald Cox 2015-05-20 02:01:29 UTC
Created attachment 1027479 [details]
Normal status and notification area

Description of problem:  This is somewhat related to bug 1217844 in that
this upgrade is required by plasma-workspaces.  I'm creating a specific ticket 
however, because this problem is related specifically to f22-kde-theme.

When upgrade is applied, all the icons disappear from status & notification.  I'm attaching a png to show the normal behavior.  After the upgrade, the icons are all missing in both the system tray area and the pop-up notification area.  
When you downgrade to f22-kde-theme-22.1-1 they all magically reappear.

Version-Release number of selected component (if applicable):
f22-kde-theme-22.3-1

How reproducible:
Upgrade to 22.3-1


Steps to Reproduce:
1.  dnf upgrade f22-kde-theme-22.3-1
2.
3.

Actual results:  Poof, system tray icons and notification area icons are gone


Expected results:
All icons show as in the attached png file


Additional info:
This is a requirement for plasma-workspace

Comment 1 Gerald Cox 2015-05-20 04:16:31 UTC
I discovered the following:
From f22-kde-theme-22.1-1 go into system settings and set the workspace theme look and feel to breeze
logout and log back in (not sure if this was required but is what I did)
now upgrade to 22.3-1
logout and log back in
You'll notice that the Fedora Theme is gone, but the status and notification 
area icons are working fine.

Now, upgrade plasma-workspace
logout and log back in

Now the Fedora Theme is back, however the translucency of the panel matches the breeze theme.  

I went ahead and selected the breeze theme and am using that.  Everything appears to be working normally.  The Fedora icon doesn't appear in the launcher,  I don't use it, I like the KDE icon, so not sure if that is because I earlier reset it or if the Fedora theme isn't working correctly.  As far as I can tell, it now looks identical to breeze - but again, I prefer breeze anyway.

Comment 2 Gerald Cox 2015-05-20 04:21:57 UTC
(In reply to Gerald Cox from comment #0)
> Created attachment 1027479 [details]
> Normal status and notification area
> 
> Description of problem:  This is somewhat related to bug 1217844 in that
> this upgrade is required by plasma-workspaces.  I'm creating a specific

Sorry, I referenced the wrong bug... should be bug 1222737

Comment 3 Jan Grulich 2015-05-20 06:56:36 UTC
That could be cause by renaming of Fedora Twenty Two look-and-feel package in the recent update. That would explain why changing it to Breeze and back to Fedora look-and-feel package fixes this problem. I don't know whether there is something we can do about this. This will be broken probably only to those who updated to plasma-workspace-5.3.0-5.fc22 yesterday before the update was cancelled and updating from 5.3.0-4 directly to 5.3.0-6 should be okay.

Comment 4 Gerald Cox 2015-05-20 17:04:03 UTC
(In reply to Jan Grulich from comment #3)
Yes, agreed.  The odds that many people will be affected by this should be extremely low - and if they do encounter, at least we have a documented workaround.


Note You need to log in before you can comment on or make changes to this bug.