Bug 1223070 - Two-finger right click stopped working
Summary: Two-finger right click stopped working
Keywords:
Status: CLOSED DUPLICATE of bug 1206961
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-19 17:52 UTC by bztdlinux
Modified: 2015-05-19 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-19 22:46:13 UTC


Attachments (Terms of Use)

Description bztdlinux 2015-05-19 17:52:32 UTC
libinput 0.15.0 in Fedora 22 seems to have suddenly changed the trackpad defaults on my Thinkpad W540. Two-finger right click no longer works. It can be restored with:

$ xinput set-prop 13 283 0 1

Unfortunately the GNOME 3 GUI has no way to choose this.

Comment 1 Peter Hutterer 2015-05-19 22:46:13 UTC
gsettings has a toggle for it, under:
org.gnome.desktop.peripherals.touchpad click-method

what's the value of that and does the xorg driver property change when you toggle it? gsettings range org.gnome.desktop.peripherals.touchpad click-method tells you the allowed values

Gnome has (accidentally) enabled clickfinger behaviour on most touchpads until a recent update, now it takes what the libinput default is for a given device. For a W540, this would be software buttons so if the click method shows "default", everything is working as expected.

*** This bug has been marked as a duplicate of bug 1206961 ***

Comment 2 bztdlinux 2015-05-19 23:08:01 UTC
It does in fact show 'default', so I guess this is the new intended behavior.

The right click button is in the wrong location on the W540 trackpad, but that is a separate bug.

Comment 3 Peter Hutterer 2015-05-19 23:46:23 UTC
can you file a separate bug against libinput for that please?

we tested with the T540 which should be the same trackpad, so unless there's a kernel issue I'm not sure where this comes from. Please include the output of the touchpad-edge-detector tool and the evemu-describe output for that touchpad.

And maybe try to measure where the buttons are and where you'd expect them to be. Thanks.


Note You need to log in before you can comment on or make changes to this bug.