Bug 1223194 - set FF38 as the supported browser for RHEV
Summary: set FF38 as the supported browser for RHEV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.1
: ---
Assignee: Greg Sheremeta
QA Contact: Petr Kubica
URL:
Whiteboard:
Depends On: 1200470 1200499 1218371
Blocks: 1273034
TreeView+ depends on / blocked
 
Reported: 2015-05-20 05:23 UTC by Sarvesh Pandit
Modified: 2019-06-13 08:31 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The Administration Portal and the User Portal now support Mozilla Firefox 38 Extended Support Release (ESR) as the client browser.
Clone Of:
: 1273034 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:06:45 UTC
oVirt Team: UX
mgoldboi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 46825 master MERGED webadmin: set Firefox 38 as the supported browser. Never
oVirt gerrit 46958 ovirt-engine-3.6 MERGED webadmin: set Firefox 38 as the supported browser. Never
oVirt gerrit 48698 ovirt-engine-3.5 MERGED webadmin: set Firefox 38 as the supported browser. Never
Red Hat Bugzilla 1259804 None None None Never

Internal Links: 1259804

Description Sarvesh Pandit 2015-05-20 05:23:42 UTC
Description of problem:
When you try to open login page of Administration portal from firefox version 31+, the following message will be displayed:
This Browser version isn't optimal for displaying the application graphics (refer to Documentation for details)

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.5.1.1-0.1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.open login page of Administration portal from firefox-38.0-4.el6_6.x86_64 on RHEL 6.6
2.
3.

Actual results:
This Browser version isn't optimal for displaying the application graphics (refer to Documentation for details)

Expected results:
No message

Additional info:
This is not only with firefox but also with Internet Explorer(11.0.9600.17801).

Comment 1 Einav Cohen 2015-05-21 04:58:08 UTC
I assume that Firefox 38 (which is the current FF ESR) has been pushed to RHEL recently. 

AFAIK, some problems were encountered when testing the RHEV GUI on FF38, however they were all resolved and tests of the RHEV GUI on FF38 have passed successfully since then. 
@Pavel/Pavel - can you please confirm that?

re: the "Additional info" in Comment #0: I am not sure what the problem with IE11 is - it is supposed to be a supported browser (IE9 and above are supported for the web-admin), hence the message should not appear for it. If the message is indeed displayed for IE11, and assuming the IE browser is not configured to run in IE8 (or lower) compatibility mode [1], it is indeed a bug. 

[1] I actually think that we have a piece of code that forces IE11 to report itself as IE10 (so that we will be able to load the relevant GWT permutation in the IE browser) - see https://gerrit.ovirt.org/#/c/23367/. 
I am not sure if setting the compatibility mode manually within the browser settings overrides the effect of our piece of code or not.

Comment 7 Einav Cohen 2015-09-21 13:01:34 UTC
not a 3.5.5 blocker - pushing to 3.5.6 for now.

Comment 8 Einav Cohen 2015-10-08 13:44:06 UTC
backport merged - MODIFIED?

Comment 11 Petr Kubica 2016-02-11 13:20:24 UTC
Verified in 3.6.3-0.1
FF 38.6.0 ESR

Comment 13 errata-xmlrpc 2016-03-09 21:06:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.