Bug 1223317 - BSod occurs When installing latest Windows Enterprise Insider 10 and windows server 2016 Preview
Summary: BSod occurs When installing latest Windows Enterprise Insider 10 and windows ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: ---
Assignee: Radim Krčmář
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-20 10:23 UTC by Mike Cao
Modified: 2019-09-12 08:29 UTC (History)
21 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-16.el7
Doc Type: Deprecated Functionality
Doc Text:
Windows guest virtual machine support limited As of Red Hat Enterprise Linux 7, Windows guest virtual machines are supported only under specific subscription programs, such as Advanced Mission Critical (AMC).
Clone Of:
Environment:
Last Closed: 2015-12-04 16:42:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Mike Cao 2015-05-20 10:23:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Tried on following qemu-kvm
qemu-kvm-rhev-2.2.0-8.el7.x86_64
qemu-kvm-rhev-0.12.1.2-2.469.el6.x86_64
qemu-kvm-rhev-1.5.3-60.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Trying installing windows 10 insider preview or windows server 2016 
CLI:
/usr/libexec/qemu-kvm -name 103PNC2016646TV -enable-kvm -m 6G -smp 4 -uuid b503e8e6-1f58-49ce-820e-bc4ace245458 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/103PNC2016646TV,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=103PNC2016646TV,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_technical_preview_2_x64_dvd_6651466.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=103PNC2016646TV.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:47:3f:a6:5a,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -device pvpanic,id=pvpanic0,ioport=0x050
2.
3.

Actual results:
Guest BSod Directly 

Expected results:
no bsod occurs.

Additional info:
1.It might not related to qemu-kvm but Did not hit this issue on previous beta version windows 10/2016.It happened on latest beta version windows 10.

2#sha1sum of images
587d610bc899f14552903272ed0631bc85d18b6e  en_windows_10_enterprise_insider_preview_10074_x64_dvd_6651209.iso
37d1c488036f370b842a8d7aac3e40a271e87cb0  en_windows_10_enterprise_insider_preview_10074_x86_dvd_6651242.iso
5efb981c94e1223c85f3bb504d04e0642a85c1d4  
aa2bd2f08ab8543d6eb51fcdd50f8ced219a4fe6  en_windows_server_technical_preview_2_x64_dvd_6651466.iso

3.The SHA1SUM is same as as the value provide in MSDN website.

4. QE Test previous Beta iso before ,did not hit the issue.
       'en_windows_10_technical_preview_9926_x86_dvd_6245077.iso':'1ae10947cc297ae299e1c81f95812efbb5c84121',
                    'en_windows_10_technical_preview_9926_x64_dvd_6245061.iso':'6a95316728299d95249a29fbeb9676ded23b8beb',
                    'en_windows_server_technical_preview_x64_dvd_5554304.iso':'d9300b00f8140439fff22e98fa7b4c82c1366040'}

Comment 31 Paolo Bonzini 2015-06-25 10:05:05 UTC
For this particular MSR it is okay to return the default, i.e. 55h, but there may be other MSRs that Windows tries to access.

Vadim, can you try running KVM with the ignore_msrs parameter set to Y, and grab from dmesg a list of model specific registers that Windows tries to read?

Comment 32 Vadim Rozenfeld 2015-06-25 10:12:29 UTC
(In reply to Paolo Bonzini from comment #31)
> For this particular MSR it is okay to return the default, i.e. 55h, but
> there may be other MSRs that Windows tries to access.
> 
> Vadim, can you try running KVM with the ignore_msrs parameter set to Y, and
> grab from dmesg a list of model specific registers that Windows tries to
> read?

[vrozenfe@oscar qemu]$ dmesg | grep -i msr
[6340893.800233] kvm [28248]: vcpu0 unhandled rdmsr: 0x606
[6340918.337790] kvm [28248]: vcpu1 unhandled rdmsr: 0x606
[6340954.032611] kvm [28290]: vcpu1 ignored rdmsr: 0x606
[6340954.032614] kvm [28290]: vcpu1 ignored rdmsr: 0x641

Comment 33 Amnon Ilan 2015-07-07 09:40:42 UTC
A new build of Windows 10 (build 10162) is available here:
http://windows.microsoft.com/en-us/windows/preview-iso

Please check if the problem is still there.

Comment 34 Bandan Das 2015-07-07 23:56:50 UTC
(In reply to Amnon Ilan from comment #33)
> A new build of Windows 10 (build 10162) is available here:
> http://windows.microsoft.com/en-us/windows/preview-iso
> 
> Please check if the problem is still there.

With build 10162, the GP due to missing MSRs is not reproducible anymore (bug 1232894) but the bsod that this bug is tracking due to the cflushopt instruction is still present. I didn't close bug 10162 yet though, it's probably best to wait for a release before closing it. Vadim, do you want to try the 32-bit version ?

Comment 35 Vadim Rozenfeld 2015-07-08 02:19:21 UTC
(In reply to Bandan Das from comment #34)
> (In reply to Amnon Ilan from comment #33)
> > A new build of Windows 10 (build 10162) is available here:
> > http://windows.microsoft.com/en-us/windows/preview-iso
> > 
> > Please check if the problem is still there.
> 
> With build 10162, the GP due to missing MSRs is not reproducible anymore
> (bug 1232894) but the bsod that this bug is tracking due to the cflushopt
> instruction is still present. I didn't close bug 10162 yet though, it's
> probably best to wait for a release before closing it. Vadim, do you want to
> try the 32-bit version ?

Also cannot reproduce the crash, mentioned in comment #30, with 32-bit version (build 10162).

Comment 38 Miroslav Rezanina 2015-08-07 09:31:09 UTC
Fix included in qemu-kvm-rhev-2.3.0-16.el7

Comment 39 juzhang 2015-08-11 07:59:40 UTC
Hi Miroslav,

Please add this bz into RHEL7.2 qemu-kvm-rhev erratum, thx.

Best Regards,
Junyi

Comment 41 mazhang 2015-08-14 08:32:11 UTC
Reproduce this bug on qemu-kvm-rhev-2.3.0-15.el7.x86_64.

Host:
3.10.0-304.el7.x86_64
qemu-kvm-rhev-2.3.0-15.el7.x86_64

Guest:
en_windows_10_enterprise_x64_dvd_6851151.iso

Steps:
1. Just start install win10 with following command line:
/usr/libexec/qemu-kvm \
-M pc \
-nodefaults -rtc base=utc -no-hpet \
-m 2G \
-smp 4,sockets=2,cores=2,threads=1 \
-enable-kvm \
-name rhel7.2 \
-uuid 990ea161-6b67-47b2-b803-19fb01d30d12 \
-smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67170 \
-k en-us \
-monitor stdio \
-qmp tcp:0:6662,server,nowait \
-boot menu=on \
-bios /usr/share/seabios/bios.bin \
-serial unix:/tmp/serial0,server,nowait \
-vga cirrus \
-vnc :0 \
-netdev tap,id=hostnet0,vhost=on \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=54:52:00:B6:40:22 \
-drive file=/home/en_windows_10_enterprise_x64_dvd_6851151.iso,if=none,media=cdrom,id=drive-ide0,readonly=on,format=raw \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=0 \
-drive file=/home/win10.raw,if=none,media=disk,id=drive-ide1,format=raw \
-device ide-drive,bus=ide.1,unit=0,drive=drive-ide1,id=ide1 \

Result:
Guest bsod then restart.


Verified this bug on qemu-kvm-rhev-2.3.0-17.el7.x86_64.

Result:
After update qemu-kvm, installation complete without bsod, guest works well.

So this bug has been fixed.

Comment 44 errata-xmlrpc 2015-12-04 16:42:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.