Bug 12234 - RFE: /boot on pre-existing partition not checked for <1024 cyl
RFE: /boot on pre-existing partition not checked for <1024 cyl
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 15798 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 21:58 EDT by Rod m. Stewart
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 18:22:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rod m. Stewart 2000-06-13 21:58:46 EDT
Unless I missed it.  When I installed using the text interface, doing a
workstation install.  I did not get queried about adding in extra boot
devices to lilo. 

I selected manually select partitions.  My drive is partitioned as follows:
	/dev/hda1	(regular /)
	/dev/hda2	(where I installed rh-beta1)
	/dev/hda5	(regular /usr)
	/dev/hda6	(debian potato)
	/dev/hda7	(regular /home)

During the install I only told it to put /dev/hda2 on /.  I did not have an
option to boot into any of my other partitions.  Nor did I have an option
not to run lilo.

This was anonying as the last cylinder on /dev/hda2 is > 1024, and I got a
famous "L" only on the screen.

Could a check be added to see if /boot ends past cylinder 1024 (or a lilo
which supports greater number of cylinders...)
Comment 1 Michael Fulbright 2000-06-14 10:30:18 EDT
Just so I understand - you used pre-existing partitions for the install?

If so, I think you are correct that there is not a test on whether the /boot
partition is acceptable to LILO for booting.

Comment 2 Rod m. Stewart 2000-06-14 11:02:02 EDT
Yes, I aldready had /dev/hda2 existing, which is where I installed (also the
only partition I told the installer about).

The problem with /dev/hda2 is the last cylinder is beyond 1024.
/dev/hda2          1001      3540   2560320   83  Linux
This is a 15GB drive with LBA enabled in the BIOS.  Which the current lilo does
not like, unless you pass it magic parameters.
Comment 3 Michael Fulbright 2000-08-17 17:19:33 EDT
*** Bug 15798 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2001-01-09 18:22:27 EST
Should now be done.

Test by assigning preexisting partition to > 1023 cyl. Should get warning
message before the formatting screen.
Comment 5 Brock Organ 2001-01-10 13:00:41 EST
verified fix in qa0110.0 test tree ...

Note You need to log in before you can comment on or make changes to this bug.