Bug 122351 - computer hangs after logout
computer hangs after logout
Status: CLOSED DUPLICATE of bug 123424
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 11:53 EDT by David Bentley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bentley 2004-05-03 11:53:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
loging out as either ROOT or a NORMAL user to switch between them
causes my machine to hang just showing the hourglass on a black
background.

My hardware is as follows :-

AMD K6 III/450
384 Meg of ram
ASUS P5A with latest BETA bios
MATROX G400 graphics card
MITSUBISHI Diamond Plus 72 monitor
Microsoft PS/2 wheel mouse
PS/2 keyboard

The problem persists even after a full update.

I picked gnome-sesion to report this under but it may be more to do
with a graphics card driver problem or the X-window subsystem now
employed.

NB this is definatly not a hardware problem as RH9 is installed on
another disk drive and works flawlessly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.log out as the current user
2.
3.
    

Actual Results:  loging out as either ROOT or a NORMAL user to switch
between them causes my machine to hang just showing the hourglass on a
black background.


Expected Results:  graphical login screen being displayed.

Additional info:
Comment 1 Karl-Olov Serrander 2004-05-06 03:14:15 EDT
I have almost the same problem with my Dell Optiplex GX240 with ATI
Rage 128 Pro Ultra TF using the r128 driver in X. When i logout from
Gnome the screen goes black and the machine freeze completely, not
even hourglass and does not respond to ping anymore. Choosing shutdown
or restart works, also logging out via Ctrl-Alt-Backspace works.
Machine is fully updated including kernel-2.6.5-1.350.
Option "NoAccel" "yes" in /etc/X11/xorg.conf makes the problem
disappear but makes screenupdates very slow.
Comment 2 David Bentley 2004-05-25 18:35:11 EDT
Having finally got all of the Core 2 release CD's burnt and tested I
have installed it cleanly on the disc where test 3 was and the problem
still persists but slightly differently in that the screen is totally
blank with no hour glass cursor now and as before the only way out is
to reset the machine.

I have edited the /etc/X11/xorg.conf file putting in the line Option
"NoAccel" "yes" as the last line in the device section and as Karl
observed in test 3 the problem goes away in the release version.

I am updating the bug from test3 to release 2
Comment 3 Karl-Olov Serrander 2004-05-26 05:38:20 EDT
I have found that commenting Load "dri" is a much better way for me to
work around the problem. Works for me in FC2 at least.
Comment 4 David Bentley 2004-05-30 17:34:28 EDT
Yes I agree it produces much improved screen updates compared to the
original FIX of adding Option "NoAccel" "yes" in /etc/X11/xorg.conf
Comment 5 Ray Strode [halfline] 2004-06-10 16:38:14 EDT
Reassigning bug to xorg-x11 component.
Comment 6 David Bentley 2004-06-12 17:46:58 EDT
Having read bug report 125762 re a matrox millenium graphics card it
would definately suggest that the problem described in this bug report
was relatated to the MGA driver also.
Comment 7 Kristian Høgsberg 2004-08-25 21:41:42 EDT

*** This bug has been marked as a duplicate of 123424 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:02:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.