Bug 1223717 - [6.6_3.5.z]Throw AttributeError exception in /var/log/ovirt.log after preventing upgrades from 6.6-3.4 to 6.6-3.5.z.
Summary: [6.6_3.5.z]Throw AttributeError exception in /var/log/ovirt.log after prevent...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Anatoly Litovsky
QA Contact: cshao
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 1224890
TreeView+ depends on / blocked
 
Reported: 2015-05-21 10:17 UTC by haiyang,dong
Modified: 2016-03-09 14:28 UTC (History)
10 users (show)

(edit)
Clone Of:
: 1224890 (view as bug list)
(edit)
Last Closed: 2016-03-09 14:28:21 UTC


Attachments (Terms of Use)
attached ovirt.log for rhevh-6.6-20150520.0.el6ev.iso (129.39 KB, text/plain)
2015-05-21 10:17 UTC, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 41347 master MERGED config: Fix logrotate migration Never
oVirt gerrit 41413 ovirt-3.5 MERGED config: Fix logrotate migration Never
Red Hat Bugzilla 1219808 None None None Never

Internal Trackers: 1219808

Description haiyang,dong 2015-05-21 10:17:02 UTC
Created attachment 1028065 [details]
attached ovirt.log for rhevh-6.6-20150520.0.el6ev.iso

Description of problem:
Throw AttributeError exception in /var/log/ovirt.log after update from 6.5 to 6.6 
May 21 07:29:21 Synchronizing log files
Config migration failed
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 68, in _run
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 56, in importConfigs
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 95, in translate_all
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 122, in translate_logrotate
  File "/usr/lib/python2.6/site-packages/ovirtnode/ovirtfunctions.py", line 1603, in get_logrotate_size
AttributeError: 'NoneType' object has no attribute 'lower'
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
..

Version-Release number of selected component (if applicable):
rhevh-6.6-20150520.0.el6ev.iso
ovirt-node-3.2.3-2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhevh-6.6-20150520.0.el6ev.iso
2. Login rhevh and press F2 to enter into shell console
3. Remove OVIRT_*VERSION parameter from the /etc/defaults/ovirt
4. persist /etc/defaults/ovirt
5. Reboot rhevh and check log info in /var/log/ovirt.log

Actual results:
1. After step5,Throw AttributeError exception in /var/log/ovirt.log

Expected results:
1. After step5, no AttributeError exception in /var/log/ovirt.log

Additional info

Comment 5 Sandro Bonazzola 2015-10-26 12:35:37 UTC
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high

Comment 6 Fabian Deutsch 2015-11-03 14:31:42 UTC
All patches have been merged, updating bug status.

Comment 8 cshao 2015-11-23 10:28:23 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test steps:
1. Clean install rhevh7.2
2. Login rhevh and press F2 to enter into shell console
3. Remove OVIRT_*VERSION parameter from the /etc/defaults/ovirt
4. persist /etc/defaults/ovirt
5. Reboot rhevh and check log info in /var/log/ovirt.log

Test result:
After step5, no AttributeError exception in /var/log/ovirt.log

So the bug is fixed, change bug status to VERIFIED.

Comment 10 errata-xmlrpc 2016-03-09 14:28:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.