Bug 1223759 - Sharding - Fix posix compliance test failures.
Summary: Sharding - Fix posix compliance test failures.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: sharding
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1227572
TreeView+ depends on / blocked
 
Reported: 2015-05-21 12:11 UTC by Krutika Dhananjay
Modified: 2016-06-16 13:03 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1227572 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:03:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-05-21 12:11:58 UTC
Description of problem:
There are a bunch of posix compliance tests that fail because of sharding translator not appropriately handling fops on symlinks.
This BZ is to be associated with all the patches sent to fix these issues.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-29 08:34:25 UTC
REVIEW: http://review.gluster.org/10995 (features/shard: Handle symlinks appropriately in fops) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Anand Avati 2015-05-30 10:07:23 UTC
REVIEW: http://review.gluster.org/10995 (features/shard: Handle symlinks appropriately in fops) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Anand Avati 2015-06-01 02:58:07 UTC
REVIEW: http://review.gluster.org/10995 (features/shard: Handle symlinks appropriately in fops) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Anand Avati 2015-06-03 13:28:18 UTC
REVIEW: http://review.gluster.org/11065 (features/shard: Skip shards resolution if lookup on /.shard returns ENOENT) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 5 Anand Avati 2015-06-03 13:37:13 UTC
COMMIT: http://review.gluster.org/10995 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 990cb828a2e9b0d83a767977712305534fac39e2
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu May 21 14:58:26 2015 +0530

    features/shard: Handle symlinks appropriately in fops
    
    (f)stat, unlink and rename must skip doing inode_ctx_get()
    of shard block size on symbolic links.
    
    Change-Id: I68688532164dd2ab491ff5c59b343174f8c4ce7f
    BUG: 1223759
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/10995
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 6 Anand Avati 2015-06-17 13:19:57 UTC
REVIEW: http://review.gluster.org/11065 (features/shard: Skip shards resolution if lookup on /.shard returns ENOENT) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 7 Anand Avati 2015-06-19 03:55:26 UTC
REVIEW: http://review.gluster.org/11065 (features/shard: Skip shards resolution if lookup on /.shard returns ENOENT) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 8 Niels de Vos 2016-06-16 13:03:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.