Bug 1223930 - hammer content-host errata does not list org options
Summary: hammer content-host errata does not list org options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: sthirugn@redhat.com
David O'Brien
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-05-21 17:57 UTC by sthirugn@redhat.com
Modified: 2017-02-23 20:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 14:01:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1219593 None None None Never

Internal Links: 1219593

Description sthirugn@redhat.com 2015-05-21 17:57:46 UTC
Description of problem:
hammer content-host errata does not list org options

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 5

How reproducible:
Always

Steps to Reproduce:
hammer> content-host errata list --id=5f9651b3-5cdd-4b24-902b-3889861e821a --content-view=rhel7partialcv
Error: Could not find organization. Some search options were missing, please 
see --help.


hammer> content-host errata list --id=5f9651b3-5cdd-4b24-902b-3889861e821a --content-view=rhel7partialcv --organization-id=1
Error: Unrecognised option '--organization-id'


See: ' content-host errata list --help'

hammer> content-host errata list --help
Usage:
     content-host errata list [OPTIONS]

Options:
 --by BY                           Field to sort the results on
 --content-view CONTENT_VIEW_NAME  Content view name
 --content-view-id CONTENT_VIEW_ID content view numeric identifier
 --environment ENVIRONMENT_NAME    Name to search by
 --environment-id ENVIRONMENT_ID    
 --full-results FULL_RESULTS       Whether or not to show all results
                                   One of true/false, yes/no, 1/0.
 --id ID                           UUID of the content host
 --name NAME                       Name to search by
 --order ORDER                     Sort field and order, eg. 'name DESC'
 --page PAGE                       Page number, starting at 1
 --per-page PER_PAGE               Number of results per page to return
 --search SEARCH                   Search string
 -h, --help                        print help


Actual results:
Org options are missing in the command as shown above.

Expected results:
Org options should be provided (or) --content-view / --environment options should be removed.

Additional info:

Comment 1 sthirugn@redhat.com 2015-05-21 18:00:16 UTC
This bug was found while verifying BZ 1219593

Comment 4 Elyézer Rezende 2015-06-09 14:48:09 UTC
It is not failing anymore on S7C2.

$ hammer content-host errata list --help
Usage:
    hammer content-host errata list [OPTIONS]

Options:
 --by BY                                        Field to sort the results on
 --content-host, --system CONTENT_HOST_NAME     Name to search by
 --content-host-id, --system-id CONTENT_HOST_ID UUID of the content host
 --content-view CONTENT_VIEW_NAME               Content view name
 --content-view-id CONTENT_VIEW_ID              content view numeric identifier
 --environment ENVIRONMENT_NAME                 Name to search by
 --environment-id ENVIRONMENT_ID
 --full-results FULL_RESULTS                    Whether or not to show all results
                                                One of true/false, yes/no, 1/0.
 --order ORDER                                  Sort field and order, eg. 'name DESC'
 --organization ORGANIZATION_NAME               Organization name to search by
 --organization-id ORGANIZATION_ID              organization ID
 --organization-label ORGANIZATION_LABEL        Organization label to search by
 --page PAGE                                    Page number, starting at 1
 --per-page PER_PAGE                            Number of results per page to return
 --search SEARCH                                Search string
 -h, --help                                     print help

hammer> content-host errata list --content-host-id=21fd993a-9abf-4506-bcfe-61c16c48e10a --organization-id 1
---|------------|------|-------|------------
ID | ERRATUM ID | TYPE | TITLE | INSTALLABLE
---|------------|------|-------|------------

hammer> content-host errata list --content-host-id=21fd993a-9abf-4506-bcfe-61c16c48e10a --organization "Default_Organization"
---|------------|------|-------|------------
ID | ERRATUM ID | TYPE | TITLE | INSTALLABLE
---|------------|------|-------|------------

hammer> content-host errata list --content-host-id=21fd993a-9abf-4506-bcfe-61c16c48e10a --organization-label "Default_Organization"
---|------------|------|-------|------------
ID | ERRATUM ID | TYPE | TITLE | INSTALLABLE
---|------------|------|-------|------------

Comment 5 sthirugn@redhat.com 2015-06-10 03:04:39 UTC
As per Comment 4, this is working fine now.  It looks this is fixed after Snap 5.  So changing the status to VERIFIED.

Comment 6 David O'Brien 2015-07-21 14:41:55 UTC
Can I assume that if this is fixed and verified it no longer requires a release note?

thanks

Comment 8 Brad Buckingham 2015-08-06 15:52:08 UTC
Since this is verified, no release not will be required.

Comment 9 Bryan Kearney 2015-08-11 13:36:27 UTC
This bug is slated to be released with Satellite 6.1.

Comment 10 Bryan Kearney 2015-08-12 14:01:50 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.