Bug 122439 - Xorg & ProSavage shows only 640x480
Summary: Xorg & ProSavage shows only 640x480
Status: CLOSED DUPLICATE of bug 120950
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-04 15:35 UTC by kchopein
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kchopein 2004-05-04 15:35:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; gl-ES; rv:1.7b)
Gecko/20040421

Description of problem:
When the system launch the X server it only works with 640x480
resolution, and it gives no error message. I've tried with the VESA
driver, but then the X server crashes and the system hangs on. It
worked fine with FC2 Test 1 (I did not try test 2).

I've tried both upgrading from FC1 and installing a new system, but
the problems persists.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot up.
2.Launch X server.
3.
    

Actual Results:  It only works with 640x480 res.

Expected Results:  It should work with resolutions up to 1024x768 (my
TFT resolution)

Additional info:

Comment 1 Julien Tane 2004-05-04 18:33:41 UTC
The same thing happened to me:

 2.6.5-1.349 #1 Sun May 2 17:00:35 EDT 2004 i686 i686 i386 GNU/Linux

xorg-x11-base-fonts-6.7.0-0.5
xorg-x11-devel-6.7.0-0.5
xorg-x11-ISO8859-14-100dpi-fonts-6.7.0-0.5
xorg-x11-Xvfb-6.7.0-0.5
xorg-x11-6.7.0-0.5
xorg-x11-ISO8859-2-75dpi-fonts-6.7.0-0.5
xorg-x11-twm-6.7.0-0.5
xorg-x11-libs-data-6.7.0-0.5
xorg-x11-doc-6.7.0-0.5
xorg-x11-Mesa-libGL-6.7.0-0.5
xorg-x11-xfs-6.7.0-0.5
xorg-x11-ISO8859-15-75dpi-fonts-6.7.0-0.5
xorg-x11-cyrillic-fonts-6.7.0-0.5
xorg-x11-syriac-fonts-6.7.0-0.5
xorg-x11-Xnest-6.7.0-0.5
xorg-x11-ISO8859-2-100dpi-fonts-6.7.0-0.5
xorg-x11-sdk-6.7.0-0.5
xorg-x11-font-utils-6.7.0-0.5
xorg-x11-xauth-6.7.0-0.5
xorg-x11-tools-6.7.0-0.5
xorg-x11-75dpi-fonts-6.7.0-0.5
xorg-x11-xdm-6.7.0-0.5
xorg-x11-ISO8859-9-100dpi-fonts-6.7.0-0.5
xorg-x11-libs-6.7.0-0.5
xorg-x11-ISO8859-15-100dpi-fonts-6.7.0-0.5
xorg-x11-100dpi-fonts-6.7.0-0.5
xorg-x11-ISO8859-9-75dpi-fonts-6.7.0-0.5
xorg-x11-Mesa-libGLU-6.7.0-0.5
xorg-x11-ISO8859-14-75dpi-fonts-6.7.0-0.5
xorg-x11-truetype-fonts-6.7.0-0.5

But to get it right I had to uncomment some 
lines in my xorg.conf file ( which was only a renamed copy of my
XfreeConfig file)

with these configuration  now it's O.K.

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "SAMTRON 70S"
        DisplaySize  340        270
 ### Uncomment if you don't want to default to DDC:
        HorizSync    30.0 - 81.0
        VertRefresh  56.0 - 85.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "savage"
        VendorName  "Videocard vendor"
        BoardName   "S3 Savage/IX"
EndSection
 
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection




Comment 2 Mike A. Harris 2004-05-05 22:46:32 UTC

*** This bug has been marked as a duplicate of 120950 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:02:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.