Bug 1224398 - NAT unavailable by default
Summary: NAT unavailable by default
Keywords:
Status: CLOSED DUPLICATE of bug 867546
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-22 19:58 UTC by Chris Murphy
Modified: 2015-05-25 21:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-25 21:19:46 UTC


Attachments (Terms of Use)
screenshot of missing NAT option (84.83 KB, image/jpeg)
2015-05-22 20:02 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2015-05-22 19:58:37 UTC
Description of problem: Fedora 22 Workstation and group Virtualization installed, but there's no network option for the VM.


Version-Release number of selected component (if applicable):
virt-manager-1.2.0-1.fc22.noarch


How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 22 
2. dnf group install Virtualization [1]
3. Create new VM in virt-manager


Actual results:

At virt-manager new vm step 5 of 5, Network selection is set to No virtual networks available.


Expected results:

NAT option should be available by default.


Additional info:

[1]
These items were installed.
(1/7): libvirt-daemon-config-network-1.2.13.1-1.fc22.x86_64.rpm
(2/7): virt-install-1.2.0-1.fc22.noarch.rpm 
(3/7): virt-manager-1.2.0-1.fc22.noarch.rpm
(4/7): virt-viewer-2.0-1.fc22.x86_64.rpm
(5/7): python-ipaddr-2.1.10-2.fc21.noarch.rpm
(6/7): libvirt-python-1.2.13-1.fc22.x86_64.rpm
(7/7): virt-manager-common-1.2.0-1.fc22.noarch.rpm

Comment 1 Chris Murphy 2015-05-22 20:02:17 UTC
Rebooting resolves this. The option "Virtual network 'default': NAT" is available in that same pop-up menu now. But it's still unexpected I have to reboot to get this option seeing as it's "the default". So I have to reboot by default? Weird UX.

Comment 2 Chris Murphy 2015-05-22 20:02:54 UTC
Created attachment 1028917 [details]
screenshot of missing NAT option

Comment 3 Cole Robinson 2015-05-25 21:19:46 UTC
Problem is it requires a libvirtd restart, its a known issue

*** This bug has been marked as a duplicate of bug 867546 ***


Note You need to log in before you can comment on or make changes to this bug.