Bug 867546 - fresh install of libvirt-daemon-config-network requires libvirtd restart to define+start default network
fresh install of libvirt-daemon-config-network requires libvirtd restart to d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
: 1224398 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 12:43 EDT by Eric Paris
Modified: 2016-05-08 20:03 EDT (History)
14 users (show)

See Also:
Fixed In Version: libvirt-1.3.3.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-08 20:03:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2012-10-17 12:43:43 EDT
Install F18

yum install -y virt-manager

This picks up libvirt including libvirt-daemon-config-network-0.10.2-3.fc18.x86_64

run virt-manager and find there is no network available. 
 virsh net-list --all    is blank

systemctl restart libvirtd.service

the default NAT network will be available.
Comment 1 Laine Stump 2012-10-17 13:27:57 EDT
So it seems that the problem is that the libvirt-daemon package is installed and started before the %post script for libvirt-deamon-config-network is run.

Perhaps that script should check for libvirtd already running and, if so, use virsh define instead of directly placing the file in /etc/libvirt?
Comment 2 Cole Robinson 2013-12-16 14:51:38 EST
Still relevant on F20
Comment 3 Michal Privoznik 2015-04-21 09:53:05 EDT
Patch was proposed on the upstream list:

https://www.redhat.com/archives/libvir-list/2015-April/msg00785.html
Comment 4 Cole Robinson 2015-05-25 17:19:46 EDT
*** Bug 1224398 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2016-04-25 17:14:03 EDT
Round #2: http://www.redhat.com/archives/libvir-list/2016-April/msg01680.html
Comment 6 Fedora Update System 2016-05-05 08:52:42 EDT
libvirt-1.3.3.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5b59b4ca5
Comment 7 Fedora Update System 2016-05-06 07:27:40 EDT
libvirt-1.3.3.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5b59b4ca5
Comment 8 Fedora Update System 2016-05-08 20:03:19 EDT
libvirt-1.3.3.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.