Bug 1225282 - Hide warnings from yum when executed from dnf
Hide warnings from yum when executed from dnf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-26 23:03 EDT by Bill Nottingham
Modified: 2015-07-10 15:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-plugins-extras-0.0.9-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-10 15:01:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2015-05-26 23:03:32 EDT
Description of problem:

If you take a system that was using yum, and fedup it to F22, dnf immmediately suggests you run dnf-2 migrate.

This command calls "yum-deprecated -q group list installed -C".

This command cannot work, because you've just done a fresh upgrade and there's no yum F22 metadata cached.

Version-Release number of selected component (if applicable):

python-dnf-plugins-extras-migrate-0.0.8-1.fc22.noarch

How reproducible:

100%

Steps to Reproduce:
1. fedup --network f22
2. Run 'yum <anything>'
3. Try and run the suggested command

Actual results:

Cannot find repomd.xml file for fedora/22/x86_64
Traceback (most recent call last):
  File "/usr/bin/dnf-2", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1077, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 126, in run
    self.migrate_groups()
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 242, in migrate_groups
    installed = self.get_yum_installed_groups(yum_exec)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 257, in get_yum_installed_groups
    env=env_config))
  File "/usr/lib64/python2.7/subprocess.py", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '[u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C']' returned non-zero exit status 1

Expected results:

Succeeds.

Additional info:

Also, it runs yum-deprecated in a way that it re-prints out the deprecation warning, even though's run internally by dnf.
Comment 1 Honza Silhan 2015-06-05 13:06:11 EDT
Printing of warnings from yum are fixed here:
https://github.com/rpm-software-management/dnf-plugins-extras/pull/31

The origin reported error is duplicate of bug 1226607
Comment 2 Fedora Update System 2015-06-30 13:13:16 EDT
dnf-plugins-extras-0.0.9-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.9-1.fc22
Comment 3 Fedora Update System 2015-07-02 13:05:26 EDT
Package dnf-plugins-extras-0.0.9-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.9-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10990/dnf-plugins-extras-0.0.9-1.fc22
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2015-07-10 15:01:49 EDT
dnf-plugins-extras-0.0.9-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.