Bug 1226607 - [abrt] dnf: subprocess.py:573:check_output:CalledProcessError: Command '[u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C']' returned non-zero exit status 1
[abrt] dnf: subprocess.py:573:check_output:CalledProcessError: Command '[u'/u...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:176935e3eaeccb699666b47802d...
:
: 1233047 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-30 21:31 EDT by Neal Gompa
Modified: 2015-08-06 04:11 EDT (History)
22 users (show)

See Also:
Fixed In Version: dnf-plugins-extras-0.0.9-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-10 15:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.82 KB, text/plain)
2015-05-30 21:31 EDT, Neal Gompa
no flags Details
File: dso_list (116 bytes, text/plain)
2015-05-30 21:31 EDT, Neal Gompa
no flags Details
File: environ (2.03 KB, text/plain)
2015-05-30 21:31 EDT, Neal Gompa
no flags Details

  None (edit)
Description Neal Gompa 2015-05-30 21:31:35 EDT
Version-Release number of selected component:
dnf-1.0.0-1.fc22

Additional info:
reporter:       libreport-2.5.1
cmdline:        /usr/bin/python -OO /bin/dnf migrate
executable:     /bin/dnf
kernel:         4.0.4-301.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
subprocess.py:573:check_output:CalledProcessError: Command '[u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C']' returned non-zero exit status 1

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1077, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 126, in run
    self.migrate_groups()
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 242, in migrate_groups
    installed = self.get_yum_installed_groups(yum_exec)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/migrate.py", line 257, in get_yum_installed_groups
    env=env_config))
  File "/usr/lib64/python2.7/subprocess.py", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
CalledProcessError: Command '[u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C']' returned non-zero exit status 1

Local variables in innermost frame:
retcode: 1
process: <subprocess.Popen object at 0x7fe9a4a5bc90>
cmd: [u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C']
unused_err: None
kwargs: {'env': {'LOGNAME': 'root', 'USER': 'root', 'QTDIR': '/usr/lib64/qt-3.3', 'XDG_VTNR': '1', 'PATH': '/sbin:/bin:/usr/sbin:/usr/bin', 'DISPLAY': ':0', 'LANG': u'C', 'TERM': 'xterm-256color', 'SHELL': '/bin/bash', 'XAUTHORITY': '/tmp/xauth-1000-_0', 'LANGUAGE': '', 'HISTSIZE': '1000', 'SUDO_USER': 'neal', 'HOME': '/root', 'USERNAME': 'root', 'SUDO_UID': '1000', 'LC_ALL': u'C', 'XDG_SESSION_ID': '1', 'SUDO_COMMAND': '/bin/dnf migrate', 'SUDO_GID': '1000', 'HOSTNAME': 'yu-ohki', 'MAIL': '/var/spool/mail/neal', 'LS_COLORS': 'rs=0:di=38;5;33:ln=38;5;51:mh=00:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=01;05;37;41:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:st=48;5;21;38;5;15:ex=38;5;40:*.tar=38;5;9:*.tgz=38;5;9:*.arc=38;5;9:*.arj=38;5;9:*.taz=38;5;9:*.lha=38;5;9:*.lz4=38;5;9:*.lzh=38;5;9:*.lzma=38;5;9:*.tlz=38;5;9:*.txz=38;5;9:*.tzo=38;5;9:*.t7z=38;5;9:*.zip=38;5;9:*.z=38;5;9:*.Z=38;5;9:*.dz=38;5;9:*.gz=38;5;9:*.lrz=38;5;9:*.lz=38;5;9:*.lzo=38;5;9:*.xz=38;5;9:*.bz2=38;5;9:*.bz=38;5;9:*.tbz=38;5;9:*.tbz2=38;5;9:*.tz=38;5;9:*.deb=38;5;9:*.rpm=38;5;9:*.jar=38;5;9:*.war=38;5;9:*.ear=38;5;9:*.sar=38;5;9:*.rar=38;5;9:*.alz=38;5;9:*.ace=38;5;9:*.zoo=38;5;9:*.cpio=38;5;9:*.7z=38;5;9:*.rz=38;5;9:*.cab=38;5;9:*.jpg=38;5;13:*.jpeg=38;5;13:*.gif=38;5;13:*.bmp=38;5;13:*.pbm=38;5;13:*.pgm=38;5;13:*.ppm=38;5;13:*.tga=38;5;13:*.xbm=38;5;13:*.xpm=38;5;13:*.tif=38;5;13:*.tiff=38;5;13:*.png=38;5;13:*.svg=38;5;13:*.svgz=38;5;13:*.mng=38;5;13:*.pcx=38;5;13:*.mov=38;5;13:*.mpg=38;5;13:*.mpeg=38;5;13:*.m2v=38;5;13:*.mkv=38;5;13:*.webm=38;5;13:*.ogm=38;5;13:*.mp4=38;5;13:*.m4v=38;5;13:*.mp4v=38;5;13:*.vob=38;5;13:*.qt=38;5;13:*.nuv=38;5;13:*.wmv=38;5;13:*.asf=38;5;13:*.rm=38;5;13:*.rmvb=38;5;13:*.flc=38;5;13:*.avi=38;5;13:*.fli=38;5;13:*.flv=38;5;13:*.gl=38;5;13:*.dl=38;5;13:*.xcf=38;5;13:*.xwd=38;5;13:*.yuv=38;5;13:*.cgm=38;5;13:*.emf=38;5;13:*.ogv=38;5;13:*.ogx=38;5;13:*.aac=38;5;45:*.au=38;5;45:*.flac=38;5;45:*.m4a=38;5;45:*.mid=38;5;45:*.midi=38;5;45:*.mka=38;5;45:*.mp3=38;5;45:*.mpc=38;5;45:*.ogg=38;5;45:*.ra=38;5;45:*.wav=38;5;45:*.oga=38;5;45:*.opus=38;5;45:*.spx=38;5;45:*.xspf=38;5;45:', 'XDG_SEAT': 'seat0'}}
output: ''
popenargs: ([u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C'],)
Comment 1 Neal Gompa 2015-05-30 21:31:38 EDT
Created attachment 1032721 [details]
File: backtrace
Comment 2 Neal Gompa 2015-05-30 21:31:38 EDT
Created attachment 1032722 [details]
File: dso_list
Comment 3 Neal Gompa 2015-05-30 21:31:39 EDT
Created attachment 1032723 [details]
File: environ
Comment 4 Mihai Harpau 2015-05-31 05:02:36 EDT
Another user experienced a similar problem:

I did tried to migrate history from yum to dnf

reporter:       libreport-2.5.1
cmdline:        /usr/bin/python -OO /bin/dnf-2 migrate
executable:     /bin/dnf-2
kernel:         4.0.4-301.fc22.x86_64
package:        python-dnf-1.0.0-1.fc22
reason:         subprocess.py:573:check_output:CalledProcessError: Command '[u'/usr/bin/yum-deprecated', u'-q', u'group', u'list', u'installed', u'-C']' returned non-zero exit status 1
runlevel:       N 5
type:           Python
uid:            0
Comment 5 Honza Silhan 2015-06-04 08:35:37 EDT
Thanks for the report.
PR: https://github.com/rpm-software-management/dnf-plugins-extras/pull/31
Comment 6 Fedora Update System 2015-06-30 13:13:17 EDT
dnf-plugins-extras-0.0.9-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.9-1.fc22
Comment 7 Fedora Update System 2015-07-02 13:05:29 EDT
Package dnf-plugins-extras-0.0.9-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.9-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10990/dnf-plugins-extras-0.0.9-1.fc22
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2015-07-10 15:01:52 EDT
dnf-plugins-extras-0.0.9-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Honza Silhan 2015-07-29 06:52:26 EDT
*** Bug 1233047 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.