Bug 122532 - %postun -p /sbin/ldconfig doesn't work
%postun -p /sbin/ldconfig doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 122974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 12:01 EDT by Miloslav Trmac
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 13:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2004-05-05 12:01:54 EDT
Description of problem:
%postun -p /sbin/ldconfig
doesn't work, because ldconfig chokes on the parameter passed by
RPM.

If I understand RPM correctly, it will attempt to execute the
whole %postun script (the gconf schema removal in particular)
in the ldconfig "shell", which will fail too.

The fix is simple:

%postun
/sbin/ldconfig
[rest of %postun]

Version-Release number of selected component (if applicable):
rhythmbox-0.8.3-1

Steps to Reproduce:
1.rpm -Uvh rhythmbox-0.8.3-1
2.rpm -ev rhythmbox
  
Actual results:
messages about %postun scriptlet failing
Comment 1 Colin Walters 2004-05-10 17:13:15 EDT
*** Bug 122974 has been marked as a duplicate of this bug. ***
Comment 2 Colin Walters 2004-05-11 00:09:59 EDT
*** Bug 122974 has been marked as a duplicate of this bug. ***
Comment 3 Colin Walters 2004-05-13 13:58:44 EDT
Fixed in 0.8.3-4.

Note You need to log in before you can comment on or make changes to this bug.