Bug 1225548 - [Backup]: Misleading error message when glusterfind delete is given with non-existent volume
Summary: [Backup]: Misleading error message when glusterfind delete is given with non-...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milind Changire
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1225424
Blocks: glusterfs-3.7.2
TreeView+ depends on / blocked
 
Reported: 2015-05-27 16:21 UTC by Aravinda VK
Modified: 2015-06-20 09:48 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1225424
Environment:
Last Closed: 2015-06-20 09:48:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-05-27 16:21:17 UTC
+++ This bug was initially created as a clone of Bug #1225424 +++

+++ This bug was initially created as a clone of Bug #1224046 +++

Description of problem:
When an incorrect session name is given, it displays that the session name is invalid, or session not found. Similarly, it should give a related error message when an incorrect volume name is given.

Version-Release number of selected component (if applicable):
glusterfs-3.7.0-2.el6rhs.x86_64

How reproducible: Always

Additional info:

root@dhcp43-140 ~]# glusterfind delete 
usage: glusterfind delete [-h] [--debug] session volume
glusterfind delete: error: too few arguments
[root@dhcp43-140 ~]# glusterfind delete sess vol11
Failed to parse Volume Info: 'NoneType' object has no attribute 'findall'
[root@dhcp43-140 ~]# 
[root@dhcp43-140 ~]# glusterfind list
SESSION                   VOLUME                    SESSION TIME             
---------------------------------------------------------------------------
sess                      vol1                      2015-05-19 15:30:19      
[root@dhcp43-140 ~]# 

Expected: Glusterfind session 'sess' with 'vol11' not found

--- Additional comment from Anand Avati on 2015-05-27 09:28:31 EDT ---

REVIEW: http://review.gluster.org/10945 (glusterfind: asserting volume presence) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

Comment 1 Anand Avati 2015-05-29 06:59:06 UTC
REVIEW: http://review.gluster.org/10989 (tools/glusterfind: verifying volume presence) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 2 Anand Avati 2015-06-02 07:20:09 UTC
REVIEW: http://review.gluster.org/10989 (tools/glusterfind: verifying volume presence) posted (#2) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 3 Niels de Vos 2015-06-02 08:20:21 UTC
The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

Comment 4 Anand Avati 2015-06-04 08:19:48 UTC
REVIEW: http://review.gluster.org/10989 (tools/glusterfind: verifying volume presence) posted (#3) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 5 Niels de Vos 2015-06-20 09:48:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.