Bug 1225728 - [RFE][HC] vdsm-gluster to be build as part of RHEV vdsm build
[RFE][HC] vdsm-gluster to be build as part of RHEV vdsm build
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-4.0.2
: 4.0.2
Assigned To: Dan Kenigsberg
SATHEESARAN
: FutureFeature
Depends On:
Blocks: RHEV_HyperConverged_SLA Gluster-HC-1
  Show dependency treegraph
 
Reported: 2015-05-28 02:10 EDT by Sahina Bose
Modified: 2016-08-23 16:17 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:17:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 41568 None None None 2016-03-09 04:34 EST
oVirt gerrit 41645 None DRAFT Gluster packages are not always available Never
oVirt gerrit 41858 None NEW build: Build vdsm-gluster as part of RHEV vdsm build Never
oVirt gerrit 57862 None None None 2016-05-23 07:15 EDT
oVirt gerrit 58605 master MERGED build: enable vdsm-gluster build 2016-07-07 08:28 EDT
oVirt gerrit 60329 ovirt-4.0 MERGED build: enable vdsm-gluster build 2016-07-19 02:47 EDT
Red Hat Product Errata RHEA-2016:1671 normal SHIPPED_LIVE VDSM 4.0 GA bug fix and enhancement update 2016-09-02 17:32:03 EDT

  None (edit)
Description Sahina Bose 2015-05-28 02:10:24 EDT
Description of problem:
For the hyperconvergence use case, the VDSM from RHEV channel should be able to manage both virt and gluster. To enable this, the vdsm-gluster package has to be built as well. 

Since vdsm-gluster has a dependency on glusterfs-server packages, it should be a requirement only for HC use case.

Version-Release number of selected component (if applicable):
3.6.0

How reproducible:
N/A

Additional info:
Comment 1 Allon Mureinik 2015-06-02 06:42:38 EDT
Just a note: in order for this change not to break a regular vdsm installation, we need the updated gluster packages in the RHEL channel.

Is this acked by RHGS dev/PMs?
Comment 2 Yaniv Lavi 2015-06-02 10:47:39 EDT
(In reply to Allon Mureinik from comment #1)
> Just a note: in order for this change not to break a regular vdsm
> installation, we need the updated gluster packages in the RHEL channel.
> 
> Is this acked by RHGS dev/PMs?

We had a discussion on this.
The package will be built and delivered in RHEV, but the requirement for gluster server packages will be removed. Host deploy will install the packages on the host, if the channel is available. We need to make sure that Gluster packages fail nicely, if gluster action are ran and daemon is not installed.
Comment 3 Nir Soffer 2015-06-11 18:09:20 EDT
(In reply to Sahina Bose from comment #0)
Sahina, vdsm needs both glusterfs-cli (for /usr/sbin/gluster) and glusterfs-fuse (for /usr/sbin/mount.glusterfs), and parts from the vdsm-gluster package, implementing the gluster apis (such as glusterVolumeInfo).

These are required in any installation - not only HC - to support gluster disk using libvirt network disk, and verifying and manipulating the gluster command line options.

See the gluster-rfe patches:
https://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:gluster-rfe

Maybe the vdsm-gluster package should be broken to vdsm-gluster-client and vdsm-gluster-server?
Comment 4 Sahina Bose 2015-06-11 21:45:49 EDT
Darshan has posted a WIP patch to do this -  https://gerrit.ovirt.org/#/c/41568
Comment 5 Nir Soffer 2015-06-13 17:37:59 EDT
(In reply to Sahina Bose from comment #4)
> Darshan has posted a WIP patch to do this - 
> https://gerrit.ovirt.org/#/c/41568

This seems like the right direction, thanks!

Ala, can you check your patches on top of Darshan patch and see if it 
works for us?
Comment 6 Ala Hino 2015-11-10 02:03:33 EST
This needinfo is not relevant anymore
Comment 7 Tal Nisan 2015-11-18 05:24:37 EST
Ala/Nir, please include the correct patches in the trackers
Comment 8 Nir Soffer 2015-11-18 05:26:49 EST
(In reply to Tal Nisan from comment #7)
> Ala/Nir, please include the correct patches in the trackers

What is wrong with the current patches?
Comment 9 Sahina Bose 2016-03-08 23:01:58 EST
Is there anything pending from gluster side?
Regarding comment 2 - "We need to make sure that Gluster packages fail nicely, if gluster action are ran and daemon is not installed."
- if vdsm-gluster is not installed, the vdsm gluster commands currently fail with a generic gluster exception. Is there a change required here?
Comment 10 Yaniv Lavi 2016-03-23 05:01:05 EDT
Can we make this happen in 4.0 ?
Comment 11 Oved Ourfali 2016-03-23 05:40:56 EDT
Nir - who is handling this one?
Comment 12 Mike McCune 2016-03-28 18:13:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 13 Oved Ourfali 2016-03-30 04:28:21 EDT
(In reply to Oved Ourfali from comment #11)
> Nir - who is handling this one?

Allon?
Comment 14 Allon Mureinik 2016-03-30 06:21:16 EDT
(In reply to Yaniv Dary from comment #2)
> (In reply to Allon Mureinik from comment #1)
> > Just a note: in order for this change not to break a regular vdsm
> > installation, we need the updated gluster packages in the RHEL channel.
> > 
> > Is this acked by RHGS dev/PMs?
> 
> We had a discussion on this.
> The package will be built and delivered in RHEV, but the requirement for
> gluster server packages will be removed. Host deploy will install the
> packages on the host, if the channel is available. We need to make sure that
> Gluster packages fail nicely, if gluster action are ran and daemon is not
> installed.
They do.
Handling host deploy to bring the gluster packages in an HC usecase is up to gluster's engineering if they think it's crucial.
Comment 15 Yaniv Lavi 2016-05-09 06:58:49 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 18 Sahina Bose 2016-05-30 08:28:05 EDT
https://gerrit.ovirt.org/57862 - has been posted to install glusterfs packages as part of host-deploy.

What's next in terms of getting this package build as part of RHEV?
Comment 19 Yaniv Kaul 2016-05-30 08:49:42 EDT
(In reply to Sahina Bose from comment #18)
> https://gerrit.ovirt.org/57862 - has been posted to install glusterfs
> packages as part of host-deploy.
> 
> What's next in terms of getting this package build as part of RHEV?

Eyal - please work with Sahina to make it happen.
Comment 20 Eyal Edri 2016-05-30 09:47:50 EDT
I'm not a vdsm maintainer so I wouldn't know what exactly is needed.
The spec file for upstream vdsm needs to be updated to support it and the build script that we use also will need updating, i think it's autobuild.sh.

Yaniv B, the downstream VDSM maintainer should be able to assist.
Also once its built we'll need to add it to the content listing of packages to ship, but that will only happen for 4.1 or 4.0.z
Comment 21 Dan Kenigsberg 2016-05-30 15:50:35 EDT
We need to:
1. build d/s with --enable-gluster-mgmt, so RHEV has the gluster code
2. modify vdsm.spec so that vdsm.rpm can install without glusterfs-cli
3. pull glusterfs-cli and glusterfs-fuse during o-h-d of hyper-coverge.

these actions would let us have a single vdsm build that can (1) ship without gluster in RHEV channel and (2) provide gluster-management and gluster SD consumption in hyperconverge channel.
Comment 22 Sahina Bose 2016-05-31 05:44:15 EDT
(In reply to Dan Kenigsberg from comment #21)
> We need to:
> 1. build d/s with --enable-gluster-mgmt, so RHEV has the gluster code
> 2. modify vdsm.spec so that vdsm.rpm can install without glusterfs-cli

You mean, modify vdsm.spec without glusterfs-server, right?
glusterfs-cli and glusterfs-fuse are required for using gluster as storage domain, i.e without vdsm-gluster and is part of RHEL (optional) channels.

> 3. pull glusterfs-cli and glusterfs-fuse during o-h-d of hyper-coverge.
> 
> these actions would let us have a single vdsm build that can (1) ship
> without gluster in RHEV channel and (2) provide gluster-management and
> gluster SD consumption in hyperconverge channel.
Comment 23 Yaniv Lavi 2016-05-31 06:02:36 EDT
Why can't we create a sub package that will require the gluster bits only if installed?
Comment 24 Sahina Bose 2016-07-21 09:29:37 EDT
Moving to modified as the patch is present in vdsm tag 4.18.7
Comment 27 SATHEESARAN 2016-08-17 02:52:20 EDT
Tested with RHV 4.0.2-6 and I see that the vdsm-gluster package is now available

[root@ ~]# yum list vdsm-gluster
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
vdsm-gluster.noarch  4.18.11-1.el7ev   @rhel-7-server-rhv-4-mgmt-agent-beta-rpms
Comment 29 errata-xmlrpc 2016-08-23 16:17:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1671.html

Note You need to log in before you can comment on or make changes to this bug.