Bug 996870 - (RHEV_HyperConverged_SLA) [RFE][HC][Tracker] – RHEV-RHSS Hyper Converged Nodes Support
[RFE][HC][Tracker] – RHEV-RHSS Hyper Converged Nodes Support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ovirt-4.1.2
: ---
Assigned To: Sahina Bose
SATHEESARAN
: FutureFeature, Tracking
: 998903 1144154 1177769 (view as bug list)
Depends On: Generic_Hyper_Converged_Host 998903 1182363 1191989 1225728
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 04:16 EDT by Elad
Modified: 2017-09-15 16:20 EDT (History)
34 users (show)

See Also:
Fixed In Version: 4.1.2
Doc Type: Enhancement
Doc Text:
Feature: Support running both gluster and virtualization capabilities on same node. Reason: Utilize existing resources better. Result: Documentation at https://access.redhat.com/documentation/en-us/red_hat_hyperconverged_infrastructure/1.0/html/deploying_red_hat_hyperconverged_infrastructure/
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 08:07:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3175821 None None None 2017-09-15 16:20 EDT
Red Hat Knowledge Base (Solution) 411153 None None None Never
Red Hat Knowledge Base (Article) 2360321 None None None 2016-08-12 14:51 EDT

  None (edit)
Description Elad 2013-08-14 04:16:20 EDT
Description of problem:

It should be possible to use hosts on RHEVM as ovirt hosts (to run VMs) and also as storage hosts (gluster). 
For now, it's not possible to enable gluster service on an ovirt cluster. 
User should be able to use host as gluster host even though it has been already used to run VMs.
Comment 4 Ayal Baron 2014-01-09 13:25:31 EST
*** Bug 998903 has been marked as a duplicate of this bug. ***
Comment 10 Itamar Heim 2014-09-21 07:12:19 EDT
*** Bug 1144154 has been marked as a duplicate of this bug. ***
Comment 11 Gajanan 2014-10-19 02:28:47 EDT
Customer requested for this : 

====================== RFE Request ======================

3. What is the nature and description of the request?

> Customer wants this feature to be ported in RHEV, this feature is available only on Ovirt. They have tested on Ovirt this type of configuration, a cluster with Virt+Gluster services, 2 nodes that provide storage domain by GLUSTER, and Virt Service, all in the 2 nodes.

[In Rhev actually it is not possible to have a cluster with virt+gluster services at the same time, in rhev we have to create separate cluster with GLUSTER.]

# Use case of this feature and how important it is for them ? 

Customer back back with:
------------------------

> It is very useful. For example: have 2 nodes that have ovirt+gluster services, in this use case, customers can have a fully private cloud ( computing+storage ) 100% HA. It's very cheap but powerful solutions as private cloud entry point for an average of 10 VM (depending of hardware ) .

> Of course 10 gigabit interconnection must be created. 2 total node, every node 2 ethernet for public vlan, 2 10gigaibt for internal connection for gluster, and 2 ethernet for management .



4. Why does the customer need this? (List the business requirements here)

> with this new feature we can sell to clients a complete " private cloud " solutions with just 2 nodes. Interconnected in 10 gigabit that provide computing and storage solutions, both in HA .


5. How would the customer like to achieve this? (List the functional requirements here)

> simply adding in rhev the cluster option " Virt+Gluster " that already is active in Ovirt

8. Does the customer have any specific timeline dependencies ?

> ASAP

11. Would the customer be able to assist in testing this functionality if implemented?

> Yes. of course. we already tested in Ovirt with success.
Comment 13 Itamar Heim 2014-10-26 10:15:56 EDT
Gajanan - please note that 3 nodes would be required for as we plan to use replica 3. VMs will work as long as 2 out of the 3 nodes are up and running
Comment 14 Gajanan 2014-11-17 10:20:45 EST
Hi Itamar

should i update this to customer ?
Comment 16 Itamar Heim 2014-11-17 12:45:45 EST
We are actively looking at this as a high priority for 3.6, but planning for 3.6 is not done yet for commitment.
as mentioned in comment 13, it is already clear we will need replica 3 in gluster for a node failure to behave correctly.
(with 2 nodes, one node will survive peer failure having 2 replicas, and the other node will not be able to continue (having only 1 replica).
Comment 18 Yaniv Lavi (Dary) 2015-01-25 01:54:32 EST
*** Bug 1177769 has been marked as a duplicate of this bug. ***
Comment 22 Yaniv Lavi (Dary) 2016-05-09 07:03:51 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 30 Yaniv Lavi (Dary) 2016-12-14 11:18:01 EST
This bug had requires_doc_text flag, yet no documentation text was provided. Please add the documentation text and only then set this flag.
Comment 32 Sahina Bose 2017-06-19 02:56:59 EDT
This feature is available with ovirt 4.1

Note You need to log in before you can comment on or make changes to this bug.