Bug 1225740 - Repo Discovery - Existing product not listed to create discovered repo within.
Summary: Repo Discovery - Existing product not listed to create discovered repo within.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Jitendra Yejare
Russell Dickenson
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1232839 (view as bug list)
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-05-28 07:13 UTC by Jitendra Yejare
Modified: 2019-06-13 21:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Issue: If you attempt to create a custom product and click on the `Existing Product` radio button, you may find that the existing product list is empty. Workaround: None at this time.
Clone Of:
Environment:
Last Closed: 2015-09-15 07:22:01 UTC


Attachments (Terms of Use)
Screenshot of Repo Discovery page attached. (136.91 KB, image/png)
2015-05-28 07:13 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1786 normal SHIPPED_LIVE Satellite 6.1.2 bug fix update 2015-09-15 11:20:04 UTC
Foreman Issue Tracker 11026 None None None 2016-04-22 16:52:12 UTC

Description Jitendra Yejare 2015-05-28 07:13:01 UTC
Created attachment 1031046 [details]
Screenshot of Repo Discovery page attached.

Description of problem:
The existing list of products not listed under repo discovery to create repository within existing product. In short the existing product list is empty.

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 5 Compose 2

How reproducible:
Always

Steps to Reproduce:
1. Create a custom product under product tab.
2. Once finish with product create, Click on Repo Discovery button under product tab
3. Give URL to discover the repos.
4. Select discovered URL and Click Create Selected button.
5. Click on Existing Product radio button to create the repo withing the existing product.

Actual results:
Observed the existing product list is empty.

Expected results:
The available products list should be displayed.

Comment 2 Jitendra Yejare 2015-06-26 11:36:24 UTC
The bug still exists in sat 6.1 beta.

The Existing product not listed to create discovered repo within.

Comment 3 Eric Helms 2015-07-06 18:53:14 UTC
Created redmine issue http://projects.theforeman.org/issues/11026 from this bug

Comment 4 Og Maciel 2015-07-07 17:51:40 UTC
*** Bug 1232839 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2015-07-14 19:19:11 UTC
moving back to zstream since we have a fix and will improve customer experience.

Comment 14 Jitendra Yejare 2015-08-27 11:00:04 UTC
Verified this on Sat 6.1.2 snap 1.

The existing product has been listed to create the discovered repos within.
Not only it lists but also I can add the discovered repo in the product and sync repos too as expected.

Thanks for the fix.

Comment 16 errata-xmlrpc 2015-09-15 07:22:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1786


Note You need to log in before you can comment on or make changes to this bug.