Bug 122614 - postfix rpm misses /var/spool/postfix/etc directory
postfix rpm misses /var/spool/postfix/etc directory
Status: CLOSED DUPLICATE of bug 111923
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: postfix (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 07:40 EDT by Henning Schmiedehausen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /etc/init.d/postfix to get queue_directory from configuration (627 bytes, patch)
2004-05-06 07:51 EDT, Henning Schmiedehausen
no flags Details | Diff

  None (edit)
Description Henning Schmiedehausen 2004-05-06 07:40:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The postfix RPM is missing the /var/spool/postfix/etc directory.

As a result of this, the /etc/resolv.conf files copied into
/var/spool/postfix/etc at startup time ends up as
/var/spool/postfix/etc   (file) instead of
/var/spool/postfix/etc/resolv.conf



Version-Release number of selected component (if applicable):
postfix-2.0.11-4

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql postfix | grep var/spool/postfix/etc

    

Actual Results:  nothing

Expected Results:  Should display /var/spool/postfix/etc

Additional info:

Postfix in chroot environment is probably not able to resolve hostnames.
Comment 1 Henning Schmiedehausen 2004-05-06 07:50:17 EDT
Well, the startup script changes really suck. You might want to learn
about changes in the configuration file (e.g. the queue_directory
setting), the postconf command and basically apply the attached patch.

The same bug pretty sure applies to Fedora.
Comment 2 Henning Schmiedehausen 2004-05-06 07:51:00 EDT
Created attachment 100037 [details]
patch to /etc/init.d/postfix to get queue_directory from configuration
Comment 3 John Dennis 2004-05-06 10:53:00 EDT
This has already been resolved, but perhaps not in the manner you
prefer. Just so you understand we are no longer putting postfix in a
chroot jail. Wieste is no longer recommending chroot jails for typical
installations, the security benefits are dwarfed by the configuration
and maintenance problems especially as more postfix installations take
advantage of other system services such as SASL, LDAP, pam, etc.

*** This bug has been marked as a duplicate of 111923 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.