Bug 122620 - yum won't gracefully restart if interrupted during package install
yum won't gracefully restart if interrupted during package install
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 08:53 EDT by Tom Wood
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-26 09:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The full transcript of the sudo yum and su - yum sessions (19.76 KB, text/plain)
2004-05-06 08:54 EDT, Tom Wood
no flags Details

  None (edit)
Description Tom Wood 2004-05-06 08:53:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
Running yum via sudo generated errors of the type 

warning: setexeccon(user_u:user_r:rpm_script_t) fails from context
"user_u:user_r:user_sudo_t": Invalid argument

which is a separate issue.  But when breaking out of this yum run,
switching user to root, and rerunning "yum -y update", yum states that
there are no actions to take.


Version-Release number of selected component (if applicable):
yum-2.0.7-0.20040416

How reproducible:
Always

Steps to Reproduce:
1. sudo yum -y update
2. Observe problem related to sudo'ing the yum update.
3. Press <ctrl>-c to break out of yum during package installation.
4. su -
5. yum -y update
6. Watch in amazement as there's nothing to do, even though the
previous yum job isn't finished.
    

Actual Results:  yum didn't finish.

Expected Results:  yum should have installed the rest of the packages.

Additional info:
Comment 1 Tom Wood 2004-05-06 08:54:54 EDT
Created attachment 100040 [details]
The full transcript of the sudo yum and su - yum sessions
Comment 2 Jeff Johnson 2004-05-07 17:07:45 EDT

*** This bug has been marked as a duplicate of 122624 ***
Comment 3 Tom Wood 2004-05-07 18:24:17 EDT
This is not a duplicate of 122624.  This is a situation where yum
doesn't pick up gracefully when interrupted.  yum wasn't finished with
its previous run when interrupted.
Comment 4 Jeff Johnson 2004-07-26 09:26:35 EDT
Then this is a feature request, and the yum package will
be fixed when the maintainer decides if/when to add restartability
to yum.

Note You need to log in before you can comment on or make changes to this bug.