Bug 122624 - selinux doesn't understand sudo with respect to yum
selinux doesn't understand sudo with respect to yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 09:01 EDT by Tom Wood
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 17:06:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full transcript of "sudo yum -y update" (19.41 KB, text/plain)
2004-05-06 09:03 EDT, Tom Wood
no flags Details

  None (edit)
Description Tom Wood 2004-05-06 09:01:20 EDT
Description of problem: selinux doesn't understand sudo


Version-Release number of selected component (if applicable):
policy-1.11.2-21



How reproducible: Every time


Steps to Reproduce:
1. sudo yum -y update
2. Watch for selinux-related warnings/errors
3.
  
Actual results:
selinux warnings/errors


Expected results: Works.


Additional info:

Not sure where to file this, as it's a combo of sudo, yum, and
selinux.  I guessed policy.
Comment 1 Tom Wood 2004-05-06 09:03:24 EDT
Created attachment 100042 [details]
Full transcript of "sudo yum -y update"

Note:  I hit <ctrl>-c toward the end of this run, hence some of the latter
issues.
Comment 2 Jeff Johnson 2004-05-07 17:06:35 EDT
yum needs to be run from the role "sysadm_r".

sudo su -
yum update

is one way to achieve the sysadm_r role. There is
sudo -r sysadm_r yum update iirc, check the man page.
Comment 3 Jeff Johnson 2004-05-07 17:07:48 EDT
*** Bug 122620 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.