Bug 1226224 - [RFE] Quota: Make "quota-deem-statfs" option ON, by default, when quota is enabled.
Summary: [RFE] Quota: Make "quota-deem-statfs" option ON, by default, when quota is en...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Sachin Pandit
QA Contact:
URL:
Whiteboard:
Depends On: 1211643 1213364
Blocks: glusterfs-3.7.2
TreeView+ depends on / blocked
 
Reported: 2015-05-29 09:01 UTC by Sachin Pandit
Modified: 2015-12-01 16:45 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Enhancement
Doc Text:
Clone Of: 1213364
Environment:
Last Closed: 2015-06-20 09:49:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-01 06:48:04 UTC
REVIEW: http://review.gluster.org/11000 (features/quota : Make "quota-deem-statfs" option "on" by default, when quota is enabled) posted (#2) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 2 Anand Avati 2015-06-02 05:58:24 UTC
REVIEW: http://review.gluster.org/11000 (features/quota : Make "quota-deem-statfs" option "on" by default, when quota is enabled) posted (#3) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 3 Niels de Vos 2015-06-02 08:20:23 UTC
The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

Comment 4 Anand Avati 2015-06-03 06:57:26 UTC
REVIEW: http://review.gluster.org/11000 (features/quota : Make "quota-deem-statfs" option "on" by default, when quota is enabled) posted (#4) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 5 Anand Avati 2015-06-03 08:28:40 UTC
REVIEW: http://review.gluster.org/11000 (features/quota : Make "quota-deem-statfs" option "on" by default, when quota is  enabled) posted (#5) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 6 Anand Avati 2015-06-03 11:05:49 UTC
REVIEW: http://review.gluster.org/11000 (features/quota : Make "quota-deem-statfs" option "on" by default, when quota is  enabled) posted (#6) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 7 Anand Avati 2015-06-04 08:39:23 UTC
COMMIT: http://review.gluster.org/11000 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 0af7b774c85b184fcb8661b19c8925c0d0b74f2a
Author: Sachin Pandit <spandit@redhat.com>
Date:   Mon Apr 20 10:08:03 2015 +0530

    features/quota : Make "quota-deem-statfs" option "on" by default, when quota is  enabled
    
    As of now it is expected from user to set deem-statfs to "on" when
    quota is enabled. Better to turn it "on" by default when quota is enabled.
    
    Change-Id: I85e0b919b1bdb74ac21e256073eebcb55bcb8e2a
    BUG: 1226224
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/10299
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/11000
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 8 Niels de Vos 2015-06-20 09:49:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.