Bug 1226507 - Honour afr self-heal volume set options from clients
Summary: Honour afr self-heal volume set options from clients
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
: 1177737 (view as bug list)
Depends On:
Blocks: 1227674 1228518 1230259
TreeView+ depends on / blocked
 
Reported: 2015-05-30 05:04 UTC by Ravishankar N
Modified: 2016-06-16 13:06 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1227674 1228518 1230259 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2015-05-30 05:04:18 UTC

Comment 1 Anand Avati 2015-05-30 05:07:39 UTC
REVIEW: http://review.gluster.org/11012 (afr: honour selfheal enable/disable volume set options) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Krutika Dhananjay 2015-05-30 05:22:52 UTC
*** Bug 1177737 has been marked as a duplicate of this bug. ***

Comment 3 Anand Avati 2015-06-01 11:03:27 UTC
REVIEW: http://review.gluster.org/11012 (afr: honour selfheal enable/disable volume set options) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 4 Anand Avati 2015-06-03 10:50:50 UTC
COMMIT: http://review.gluster.org/11012 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit da111ae21429d33179cd11409bc171fae9d55194
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sat May 30 10:23:33 2015 +0530

    afr: honour selfheal enable/disable volume set options
    
    afr-v1 had the following volume set options that are used to enable/ disable
    self-heals from happening in AFR xlator when loaded in the client graph:
    cluster.metadata-self-heal
    cluster.data-self-heal
    cluster.entry-self-heal
    
    In afr-v2, these 3 heals can happen from the client if there is an inode
    refresh. This patch allows such heals to proceed only if the corresponding
    volume set options are set to true.
    
    Change-Id: I8d97d6020611152e73a269f3fdb607652c66cc86
    BUG: 1226507
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11012
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 15:17:31 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 6 Niels de Vos 2016-06-16 13:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.