Bug 1226530 - [abrt] marco: meta_rectangle_edge_aligns(): marco killed by SIGABRT [NEEDINFO]
[abrt] marco: meta_rectangle_edge_aligns(): marco killed by SIGABRT
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: marco (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:13a52351c40ca806c4faac1d2e7...
:
: 1011869 1170633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-30 06:40 EDT by Paul Cartwright
Modified: 2015-09-01 08:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.10.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 00:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fedora: needinfo? (pbcartwright)


Attachments (Terms of Use)
File: backtrace (26.03 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: cgroup (285 bytes, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: core_backtrace (9.82 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: dso_list (8.32 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: environ (1.98 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: limits (1.29 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: maps (45.98 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: mountinfo (3.53 KB, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: namespaces (85 bytes, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: open_fds (680 bytes, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: proc_pid_status (965 bytes, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details
File: var_log_messages (476 bytes, text/plain)
2015-05-30 06:40 EDT, Paul Cartwright
no flags Details

  None (edit)
Description Paul Cartwright 2015-05-30 06:40:07 EDT
Version-Release number of selected component:
marco-1.10.0-2.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        marco
crash_function: meta_rectangle_edge_aligns
executable:     /usr/bin/marco
global_pid:     6035
kernel:         4.0.4-301.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 meta_rectangle_edge_aligns at core/boxes.c:1159
 #5 apply_edge_resistance at core/edge-resistance.c:391
 #6 apply_edge_resistance_to_each_side at core/edge-resistance.c:629
 #7 meta_window_edge_resistance_for_move at core/edge-resistance.c:1162
 #8 update_move at core/window.c:7182
 #9 meta_window_handle_mouse_grab_op_event at core/window.c:7654
 #10 event_callback at core/display.c:2084
 #11 filter_func at ui/ui.c:289
 #12 gdk_event_apply_filters at gdkevents-x11.c:371
 #13 gdk_event_translate at gdkevents-x11.c:969

Potential duplicate: bug 1170633
Comment 1 Paul Cartwright 2015-05-30 06:40:09 EDT
Created attachment 1032420 [details]
File: backtrace
Comment 2 Paul Cartwright 2015-05-30 06:40:10 EDT
Created attachment 1032421 [details]
File: cgroup
Comment 3 Paul Cartwright 2015-05-30 06:40:11 EDT
Created attachment 1032422 [details]
File: core_backtrace
Comment 4 Paul Cartwright 2015-05-30 06:40:12 EDT
Created attachment 1032423 [details]
File: dso_list
Comment 5 Paul Cartwright 2015-05-30 06:40:12 EDT
Created attachment 1032424 [details]
File: environ
Comment 6 Paul Cartwright 2015-05-30 06:40:13 EDT
Created attachment 1032425 [details]
File: limits
Comment 7 Paul Cartwright 2015-05-30 06:40:14 EDT
Created attachment 1032426 [details]
File: maps
Comment 8 Paul Cartwright 2015-05-30 06:40:15 EDT
Created attachment 1032427 [details]
File: mountinfo
Comment 9 Paul Cartwright 2015-05-30 06:40:16 EDT
Created attachment 1032428 [details]
File: namespaces
Comment 10 Paul Cartwright 2015-05-30 06:40:17 EDT
Created attachment 1032429 [details]
File: open_fds
Comment 11 Paul Cartwright 2015-05-30 06:40:17 EDT
Created attachment 1032430 [details]
File: proc_pid_status
Comment 12 Paul Cartwright 2015-05-30 06:40:18 EDT
Created attachment 1032431 [details]
File: var_log_messages
Comment 13 Wolfgang Ulbrich 2015-07-04 04:53:48 EDT
*** Bug 1170633 has been marked as a duplicate of this bug. ***
Comment 14 Wolfgang Ulbrich 2015-07-04 05:02:32 EDT
upstream report
https://github.com/mate-desktop/marco/issues/63
Comment 15 Wolfgang Ulbrich 2015-08-04 07:51:47 EDT
Upstream ask to test a possible fix for this issue.
Here are scratch builds for f21 and f22.
http://koji.fedoraproject.org/koji/taskinfo?taskID=10599469
http://koji.fedoraproject.org/koji/taskinfo?taskID=10599481
Please test give feedback!
Comment 16 Wolfgang Ulbrich 2015-08-20 15:42:54 EDT
*** Bug 1011869 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2015-08-21 22:51:24 EDT
marco-1.10.2-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update marco'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13853
Comment 18 Fedora Update System 2015-08-22 12:25:11 EDT
marco-1.10.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update marco'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13850
Comment 19 Fedora Update System 2015-08-26 00:33:10 EDT
marco-1.10.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2015-09-01 08:19:43 EDT
marco-1.10.2-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.