Bug 122680 - FC2 release notes -- glibc changes
FC2 release notes -- glibc changes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
:
Depends On:
Blocks: fc-relnotes-blocker
  Show dependency treegraph
 
Reported: 2004-05-06 16:49 EDT by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 16:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2004-05-06 16:49:15 EDT
I think a number of glibc changes should be mentioned:

~ add the same NIS comments we had in the AS2.1U4/RHEL3U2 release
  notes regarding the /etc/default/nss file.

~ since this is the first release with the 2.6 kernel, we should
  mention that the POSIX timer support now is implemented in the
  kernel.  The CLOCK_MONOTONIC clock is available.

~ also new: POSIX message queue support is available.
Comment 1 Ed Bailey 2004-05-07 14:15:09 EDT
Thanks for the feedback.

I've added the /etc/default/nss file stuff.

About the other two items: Looking at a FC1 system, it appears that
POSIX timer support existed prior to the 2.6 kernel (at least the
clock_getres man page on an FC1 box seems to say so), so it this a
change in how it was implemented, or is the man page lying and this
really is brand new stuff?  CLOCK_MONOTONIC was also mentioned on that
man page as well...

As for the POSIX message queue support, is there anything we should
say about it?  For example, are there a few functions that should be
mentioned?  Is there a good site out there that gives an overview of
message queues?

The same kinds of questions apply to the POSIX timer support, too,
come to think of it... :-)
Comment 2 Jakub Jelinek 2004-05-07 14:31:57 EDT
POSIX timers have been supported in librt for several years now
(4?), but it has been a pure userland implementation, now it
is using kernel support.
POSIX message queue support is new, none of the mq_* functions has
been implemented before.
Both message queues and timers are described in the standard, which
is available also online on www.opengroup.org.  Dunno of any other
site about message queues nor timers.
Comment 3 Ulrich Drepper 2004-05-07 15:04:57 EDT
As Jakub said, we had a very poor implementation of POSIX timers. 
This is why I wrote we now have *kernel* support.  And regardless of
what some man page says, CLOCK_MONOTONIC has not been supported.  It
is definitely worthwhile mentioning it.

Same for POSIX message queues.  I would not point to some site.  Just
reference the POSIX/Unix spec, eventually pointing to the Open Group
web site.  Nothing else is needed.
Comment 4 Ed Bailey 2004-05-07 15:43:09 EDT
Ok, so this is the kind of thing where people interested in knowing
about this will know what it is when they see it, and people that
don't know what it is when they see it probably don't need to know
about it, right? :-)

How about something like this?

"A higher-quality implementation of POSIX timer support (which now
includes support for CLOCK_MONOTONIC) is now available.  This
implementation uses support built into the 2.6 kernel."

"In addition, POSIX message queue support, a new feature, has been
added to Fedora Core 2."

I was going to reference www.opengroup.org, but I wonder if that would
just cause more confusion; it's not the easiest site to navigate,
particularly if you're not that familiar with the standard.  What do
you think?

Oh, and a kind of housekeeping question: would you put these entries a
section on the kernel or a section on glibc?  Either place is fine
with me, but it wasn't obvious to me where they should land... :-)

Thanks for your help!
Comment 5 Ulrich Drepper 2004-05-07 15:50:56 EDT
> How about something like this?

OK.

> but I wonder if that would
> just cause more confusion; it's not the easiest site to navigate,

And the problem is that one would have to register to view the
specification.   So leave it out.

> would you put these entries a
> section on the kernel or a section on glibc?

The glibc section is more appropriate.  Nobody can use the
functionality without glibc.
Comment 6 Ed Bailey 2004-05-07 16:54:31 EDT
Thanks for your feedback.  I've added the text to the glibc section...

Note You need to log in before you can comment on or make changes to this bug.