Bug 1226829 - gf_store_save_value fails to check for errors, leading to emptying files in /var/lib/glusterd/
Summary: gf_store_save_value fails to check for errors, leading to emptying files in /...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Satish Mohan
QA Contact:
URL:
Whiteboard:
Depends On: 1226665
Blocks: 1253148
TreeView+ depends on / blocked
 
Reported: 2015-06-01 09:05 UTC by Gaurav Kumar Garg
Modified: 2016-06-16 13:06 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1226665
: 1253148 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-04 05:45:46 UTC
REVIEW: http://review.gluster.org/11029 (libglusterfs: write error handling when filesystem have no space left) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Anand Avati 2015-06-11 13:47:16 UTC
REVIEW: http://review.gluster.org/11029 (libglusterfs: write error handling when filesystem have no space left) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 3 Anand Avati 2015-07-27 06:48:03 UTC
REVIEW: http://review.gluster.org/11029 (libglusterfs: write error handling when filesystem have no space left) posted (#4) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 4 Anand Avati 2015-07-27 06:53:00 UTC
REVIEW: http://review.gluster.org/11029 (libglusterfs: write error handling when filesystem have no space left) posted (#5) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 5 Anand Avati 2015-07-31 05:59:38 UTC
REVIEW: http://review.gluster.org/11029 (libglusterfs: write error handling when filesystem have no space left) posted (#6) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 6 Anand Avati 2015-07-31 08:52:46 UTC
REVIEW: http://review.gluster.org/11029 (libglusterfs: write error handling when filesystem have no space left) posted (#7) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 14:51:58 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 10 Niels de Vos 2016-06-16 13:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.