Bug 1253148 - gf_store_save_value fails to check for errors, leading to emptying files in /var/lib/glusterd/
gf_store_save_value fails to check for errors, leading to emptying files in /...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Gaurav Kumar Garg
:
Depends On: 1226665 1226829
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 02:27 EDT by Gaurav Kumar Garg
Modified: 2016-06-05 19:38 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1226829
Environment:
Last Closed: 2015-09-09 05:39:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-13 02:28:34 EDT
REVIEW: http://review.gluster.org/11902 (libglusterfs: write error handling when filesystem have no space left) posted (#2) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Anand Avati 2015-08-25 02:09:32 EDT
COMMIT: http://review.gluster.org/11902 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit edcf4d35397a0a4843b3f6b107c44630c86f3d3c
Author: Gaurav Kumar Garg <ggarg@redhat.com>
Date:   Mon Jun 1 14:35:57 2015 +0530

    libglusterfs: write error handling when filesystem have no space left
    
    When no space left on filesystem and user want to perform any operation
    which result to change in /var/lib/glusterd/* files then glusterd is
    failing to write on temporary file.
    
    Fix is to handle error when write failed on temporary files due to no
    space left on file system.
    
    Change-Id: I79d595776b42580da35e1282b4a3cd7fe3d14afe
    BUG: 1253148
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/11029
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Cedric Buissart
    (cherry picked from commit e7f737e62a9ea9eac730b6ba3ef8739e497e1540)
    Reviewed-on: http://review.gluster.org/11902
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Kaushal 2015-09-09 05:39:36 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.