Bug 12269 - sort doesn't sort the way it used too
Summary: sort doesn't sort the way it used too
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 12492 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-14 15:52 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-06 21:00:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-06-14 15:52:12 UTC
Try:
ls --color=no -a|less

And then
ls --color=no -a|sort|less

This used to be the same, but now sort ignores . and Capitals and just
sorts on the first lowercased alpha char it finds, it feels like an MS
operating system, YUGH.

Comment 1 Bernhard Rosenkraenzer 2000-06-17 15:28:36 UTC
This is because of locale changes in glibc - reassigning.

Comment 2 Bill Nottingham 2000-07-06 21:00:21 UTC
*** Bug 12492 has been marked as a duplicate of this bug. ***

Comment 3 Alan Cox 2000-08-18 17:33:08 UTC
export LC_COLLATE=c I believe

Having beaten this about its been agreed that the new behaviour is standard and
correct.



Note You need to log in before you can comment on or make changes to this bug.