Bug 1227044 - support Keystone HTTPD
Summary: support Keystone HTTPD
Keywords:
Status: CLOSED DUPLICATE of bug 1170372
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: 7.0 (Kilo)
Assignee: RHOS Maint
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On: 1227042
Blocks: 1285346
TreeView+ depends on / blocked
 
Reported: 2015-06-01 19:27 UTC by Rich Megginson
Modified: 2018-07-09 13:01 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1227042
: 1285346 (view as bug list)
Environment:
Last Closed: 2016-01-06 18:47:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rich Megginson 2015-06-01 19:27:32 UTC
+++ This bug was initially created as a clone of Bug #1227042 +++

Description of problem:

Keystone upstream uses HTTPD instead of eventlet.  Our installers should set up Keystone to use HTTPD instead of eventlet.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 chris alfonso 2015-06-16 17:40:37 UTC
Couple of questions here:
Is there a deprecation of keystone with eventlet?

Currently, a yum install openstack-keystone installs keystone and by default the use of eventlet is configured. Is this a packaging issue?

Comment 5 Rich Megginson 2015-06-16 18:31:06 UTC
(In reply to chris alfonso from comment #3)
> Couple of questions here:
> Is there a deprecation of keystone with eventlet?

Yes.

> Currently, a yum install openstack-keystone installs keystone and by default
> the use of eventlet is configured. Is this a packaging issue?

Yes and no.  Yes, it is configured by default to use eventlet.  No, I'm not sure this could be solved in the rpm alone.  There is already code upstream in puppet-keystone and packstack to configure keystone to use httpd.  Since the installers have to be able to configure keystone to use httpd, there also needs to be support in rdo-manager/rhel-osp-director.  I suppose you could also file a bug against the openstack-keystone package in rdo/rhel osp as well, to get the defaults fixed too.

Comment 8 Joe Talerico 2015-11-11 23:13:49 UTC
Chris - is this going to ready for y2?

Comment 9 Jaromir Coufal 2016-01-06 18:47:38 UTC

*** This bug has been marked as a duplicate of bug 1170372 ***


Note You need to log in before you can comment on or make changes to this bug.