Bug 122783 - can not save
can not save
Status: CLOSED DUPLICATE of bug 119849
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 17:24 EDT by Sigge Kotliar
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sigge Kotliar 2004-05-07 17:24:25 EDT
Description of problem:
System-config-httpd won't make changes, whenever I try to save my
settings, it asks me whether I am certain I want to save my settings
(how can I not be?) and then, no matter what I choose, it won't quit.
I noticed it doesn't even make the changes. 
Seems like a big one... needs to be fixed before FC2


Version-Release number of selected component (if applicable):

system-config-httpd-1.2.0-3


Additional info:

Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 273, in
on_main_ok_button_clicked
    if not control.write():
  File "/usr/share/system-config-httpd/ApacheControl.py", line 63, in
write
    return stack.apache.write(force)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 770, in write
    return ApacheBase.write (force)
  File "/usr/share/system-config-httpd/ApacheBase.py", line 4346, in write
    proc.appendStylesheet(STY)
  File "/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/Processor.py",
line 178, in appendStylesheet
    sty = self._styReader.fromSrc(iSrc, extElements=self.extElements)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 160, in fromSrc
    stylesheet =  self._parseSrc(new_source)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetReader.py",
line 180, in _parseSrc
    success = self.parser.ParseFile(src.stream)
  File
"/usr/lib/python2.3/site-packages/Ft/Xml/Xslt/StylesheetHandler.py",
line 348, in startElement
    raise e
Ft.Xml.Xslt.XsltException: In stylesheet
file:///usr/share/system-config-httpd/httpd.conf.xsl, line 2, column 0:
Invalid number attribute value '1.0'
Comment 1 Ben Levenson 2004-05-26 15:17:28 EDT
Traceback is slightly different, but this looks like a dup of 
bug# 119849.

*** This bug has been marked as a duplicate of 119849 ***
Comment 2 Stein Magne Bjorklund 2004-06-28 12:48:14 EDT
Yes it is different, and the solution used on
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119849

Dont work. I have this on a final version of FC2, clean install and
with all fixes installed.
Comment 3 Guillaume ZITTA 2004-07-30 09:22:08 EDT
Hi,

change in /usr/share/system-config-httpd/httpd.conf.xsl:
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
version="1.0">
to
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
version="1">

Now it works.
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.