Bug 1227920 - Install applicable errata task missed reporting kernel packages
Summary: Install applicable errata task missed reporting kernel packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-06-03 20:15 UTC by sthirugn@redhat.com
Modified: 2019-04-01 20:27 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 17:08:49 UTC


Attachments (Terms of Use)
errata info (92.74 KB, image/png)
2015-06-03 20:18 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 1138 High CLOSED - CURRENTRELEASE Install applicable errata consumer task does not report kernel packages were updated 2016-04-05 20:34:39 UTC

Description sthirugn@redhat.com 2015-06-03 20:15:57 UTC
Description of problem:
Install applicable errata task missed reporting kernel packages

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 6

How reproducible:
Always

Steps to Reproduce:
1. Go to Content -> Errata -> Find an errata which has kernel updates.  I used RHSA-2015:0987 in this case.
2. Review the affected packages, in this case:
Affected Packages
    kernel-3.10.0-229.4.2.el7.x86_64
    kernel-abi-whitelists-3.10.0-229.4.2.el7.noarch
    kernel-debug-3.10.0-229.4.2.el7.x86_64
    kernel-debug-devel-3.10.0-229.4.2.el7.x86_64
    kernel-devel-3.10.0-229.4.2.el7.x86_64
    kernel-doc-3.10.0-229.4.2.el7.noarch
    kernel-headers-3.10.0-229.4.2.el7.x86_64
    kernel-tools-3.10.0-229.4.2.el7.x86_64
    kernel-tools-libs-3.10.0-229.4.2.el7.x86_64
    perf-3.10.0-229.4.2.el7.x86_64 
3. Apply this errata in one or more content hosts.

Actual results:
kernel and kernel-devel package installs are not reported:

In Sat6 -> After installation review the Install Applicable Errata task output:
kernel-tools-libs-3.10.0-229.4.2.el7.x86_64
kernel-tools-3.10.0-229.4.2.el7.x86_64
kernel-headers-3.10.0-229.4.2.el7.x86_64

In the client -> oh Check the yum transaction in the client: #yum history info n 

Packages Altered:
    Install kernel-3.10.0-229.4.2.el7.x86_64            @rhel-7-server-rpms
    Install kernel-devel-3.10.0-229.4.2.el7.x86_64      @rhel-7-server-rpms
    Updated kernel-headers-3.10.0-229.el7.x86_64        @beaker-Server/7.1
    Update                 3.10.0-229.4.2.el7.x86_64    @rhel-7-server-rpms
    Updated kernel-tools-3.10.0-229.el7.x86_64          @beaker-Server/7.1
    Update               3.10.0-229.4.2.el7.x86_64      @rhel-7-server-rpms
    Updated kernel-tools-libs-3.10.0-229.el7.x86_64     @beaker-Server/7.1
    Update                    3.10.0-229.4.2.el7.x86_64 @rhel-7-server-rpms

Expected results:
all the affected packages should be reported.  In this case kernel and kernel-devel too.

Additional info:

Comment 1 sthirugn@redhat.com 2015-06-03 20:18:02 UTC
Created attachment 1034453 [details]
errata info

Comment 2 sthirugn@redhat.com 2015-06-03 20:18:19 UTC
Created attachment 1034454 [details]
task output

Comment 4 Walden Raines 2015-06-23 13:56:23 UTC
We believe this to be a pulp bug.  Likely the kernel and kernel-devel packages are being marked as "installs" instead of "updates".

Comment 5 Brad Buckingham 2015-07-14 17:30:42 UTC
As a workaround, the user can review the content host's package profile to confirm that the expected packages (kernel & kernel-devel) have been updated.

Comment 6 pulp-infra@redhat.com 2015-07-14 20:30:16 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 7 pulp-infra@redhat.com 2015-07-14 20:30:17 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 8 pulp-infra@redhat.com 2015-07-17 15:00:18 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2016-02-29 23:30:47 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 12 pulp-infra@redhat.com 2016-03-08 19:30:45 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 13 pulp-infra@redhat.com 2016-03-16 13:57:06 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 15 pulp-infra@redhat.com 2016-03-23 19:01:23 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 16 pulp-infra@redhat.com 2016-04-05 20:34:40 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 18 Brad Buckingham 2016-08-02 18:35:18 UTC
This should have been solved in Satellite 6.2.  Moving to ON_QA for verification.

Comment 19 Radovan Drazny 2017-09-22 10:02:51 UTC
Verified on Satellite 6.3 Snap 16
Client side:
pulp*2.13.3-1.el7sat

Started with a RHEL 7.4 Server client, registered to the Satellite.  RHSA-2017:2679 erratum showed up as installable, scheduled an installation, with following results:

Sat 6.3 server:
Result: Success

Output:

kernel-3.10.0-693.2.2.el7.x86_64
kernel-devel-3.10.0-693.2.2.el7.x86_64
kernel-headers-3.10.0-693.2.2.el7.x86_64
kernel-tools-3.10.0-693.2.2.el7.x86_64
kernel-tools-libs-3.10.0-693.2.2.el7.x86_64
python-perf-3.10.0-693.2.2.el7.x86_64


Client: 
yum history info 14
Loaded plugins: enabled_repos_upload, package_upload, product-id, search-disabled-repos, subscription-manager
Transaction ID : 14
Begin time     : Fri Sep 22 05:29:31 2017
Begin rpmdb    : 669:0756ee0b784a0d588d5de81981e1fa70ef2b9bef
End time       :            05:30:22 2017 (51 seconds)
End rpmdb      : 671:2aeef109c0b3567158406c7af28bee44d8524818
User           : System <unset>
Return-Code    : Success
Transaction performed with:
    Installed     rpm-4.11.3-25.el7.x86_64                  @beaker-Server/7.4
    Installed     subscription-manager-1.19.21-1.el7.x86_64 @beaker-Server/7.4
    Installed     yum-3.4.3-154.el7.noarch                  @beaker-Server/7.4
    Installed     yum-metadata-parser-1.1.4-10.el7.x86_64   @beaker-Server/7.4
Packages Altered:
    Install kernel-3.10.0-693.2.2.el7.x86_64            @rhel-7-server-rpms
    Install kernel-devel-3.10.0-693.2.2.el7.x86_64      @rhel-7-server-rpms
    Updated kernel-headers-3.10.0-693.el7.x86_64        @beaker-Server/7.4
    Update                 3.10.0-693.2.2.el7.x86_64    @rhel-7-server-rpms
    Updated kernel-tools-3.10.0-693.el7.x86_64          @beaker-Server/7.4
    Update               3.10.0-693.2.2.el7.x86_64      @rhel-7-server-rpms
    Updated kernel-tools-libs-3.10.0-693.el7.x86_64     @beaker-Server/7.4
    Update                    3.10.0-693.2.2.el7.x86_64 @rhel-7-server-rpms
    Updated python-perf-3.10.0-693.el7.x86_64           @beaker-Server/7.4
    Update              3.10.0-693.2.2.el7.x86_64       @rhel-7-server-rpms
history info
Uploading Enabled Reposistories Report

VERIFIED

Comment 20 Bryan Kearney 2018-02-21 17:08:49 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:0336


Note You need to log in before you can comment on or make changes to this bug.