Bug 122801 - ifup exits before setting wireless options when bridging
ifup exits before setting wireless options when bridging
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 164509 183335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 04:01 EDT by Steven Pritchard
Modified: 2014-03-16 22:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 8.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 17:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Pritchard 2004-05-08 04:01:45 EDT
Description of problem:
When setting up bridged interfaces, any wireless options are ignored
because of an apparently bogus "exit 0" in /sbin/ifup that causes it
to exit before wireless options are processed.  The following seems to
fix it:

--- /sbin/ifup  2003-11-07 08:59:26.000000000 -0600
+++ /sbin/ifup  2004-05-08 02:54:51.405951000 -0500
@@ -180,7 +180,6 @@
       # Upon adding a device to a bridge, 
       # it's necessary to make radvd reload its config
       [ -r /var/run/radvd/radvd.pid ] && kill -HUP `cat
/var/run/radvd/radvd.pid`
-      exit 0
 fi 
 
 # now check the real state

Version-Release number of selected component (if applicable):
initscripts-7.42.2-1

How reproducible:
Every time.

Steps to Reproduce:
1. Create a bridge interface (TYPE=Bridge).
2. Add a wireless interface (BRIDGE=<bridge interface>, TYPE=Wireless)
and set some wireless options (ESSID, KEY, etc.).
3. Watch those options be silently ignored when bringing up the interface.
  
Actual results:
iwconfig on the wireless interface shows whatever the default (driver)
settings for the card are, such as ESSID "test".

Expected results:
iwconfig should report the options in ifcfg-<interface>.  Removing
that one line from /sbin/ifup makes this work.

Additional info:
I haven't had a chance to see if this is still broken in FC2/rawhide yet.
Comment 1 Bill Nottingham 2004-05-21 14:35:41 EDT
Does just moving the 'is_wireless...' check & code above the bridge
code work for you?
Comment 2 Bill Nottingham 2005-09-30 17:17:24 EDT
is_wireless_... check moved in initscripts-8.17-1. Please try this and see if it
works for you.
Comment 3 Bill Nottingham 2005-10-03 14:05:07 EDT
*** Bug 164509 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2006-02-28 12:05:45 EST
*** Bug 183335 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.